summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-03-07 17:55:27 +0100
committerSebastian Pipping <sping@gentoo.org>2020-03-07 17:57:07 +0100
commit9f1cd717bfc4125f4bbc97fbf4b2b03960d99181 (patch)
treec67a8380fb1de117c25eb03c818fde2fbbbbb979 /dev-python/ujson
parentprofiles: no shadow for prefix (diff)
downloadgentoo-9f1cd717bfc4125f4bbc97fbf4b2b03960d99181.tar.gz
gentoo-9f1cd717bfc4125f4bbc97fbf4b2b03960d99181.tar.bz2
gentoo-9f1cd717bfc4125f4bbc97fbf4b2b03960d99181.zip
dev-python/ujson: 2.0.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.92, Repoman-2.3.20
Diffstat (limited to 'dev-python/ujson')
-rw-r--r--dev-python/ujson/Manifest1
-rw-r--r--dev-python/ujson/ujson-2.0.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ujson/Manifest b/dev-python/ujson/Manifest
index 6e3b3d1940df..ba206208b55a 100644
--- a/dev-python/ujson/Manifest
+++ b/dev-python/ujson/Manifest
@@ -1 +1,2 @@
DIST ujson-1.35.tar.gz 192027 BLAKE2B 320058e7142f2264bee8b02a411bedb3b32d1c2fc86157eb47272f75cb401e6c75ce7d9e3dba5092cd1db99dbded8804347d4c7be11eaedb47bc8b4b8125fbd3 SHA512 931d8f574fc4920c9ded48369774666060e951f40982606ce9f1d9de3420004042af7d797075a54d92a2b25c4f313572a5e1a30f3bc8ce387ef8f3881193eee7
+DIST ujson-2.0.0.tar.gz 7126998 BLAKE2B 10524a96af35524e2a4390cec4d974874e5f8f9e4a60e369b24861afbfc8208961100cca73a2ceab4c03729013cbacc795b7ce80b9e3beccf0ec674cb24e097a SHA512 c6b4845b3ce05bdae62d3b231f3bb14cd8efccedd7e5bda8c45e524e8c91b5284e7dea7f92175e6ef21437a32b1bfb87588342d7685877418fd76a92ecef8f57
diff --git a/dev-python/ujson/ujson-2.0.0.ebuild b/dev-python/ujson/ujson-2.0.0.ebuild
new file mode 100644
index 000000000000..343cf57ed7bb
--- /dev/null
+++ b/dev-python/ujson/ujson-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="https://pypi.org/project/ujson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytz[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ "${PYTHON}" tests/test_ujson.py || die
+}