summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-02-16 10:40:03 +0200
committerSam James <sam@gentoo.org>2023-02-18 07:15:56 +0000
commit7c7646ef2d2990e21cb61af9b1bc590e418980f9 (patch)
treede1cfbb5fd226021826fdd90f74af7e6ddc01a58 /dev-python/unasync/unasync-0.5.0-r1.ebuild
parentdev-python/ensurepip-pip: Bump to 23.0.1 (diff)
downloadgentoo-7c7646ef2d2990e21cb61af9b1bc590e418980f9.tar.gz
gentoo-7c7646ef2d2990e21cb61af9b1bc590e418980f9.tar.bz2
gentoo-7c7646ef2d2990e21cb61af9b1bc590e418980f9.zip
dev-python/unasync: bump to python3.11 and use PEP517
* Rename to SRC_URI file to include .gh Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/unasync/unasync-0.5.0-r1.ebuild')
-rw-r--r--dev-python/unasync/unasync-0.5.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/unasync/unasync-0.5.0-r1.ebuild b/dev-python/unasync/unasync-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..ec4f70158a15
--- /dev/null
+++ b/dev-python/unasync/unasync-0.5.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="The async transformation code"
+HOMEPAGE="
+ https://github.com/python-trio/unasync/
+ https://pypi.org/project/unasync/
+"
+SRC_URI="https://github.com/python-trio/unasync/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinxcontrib-trio \
+ dev-python/sphinx-rtd-theme
+
+distutils_enable_tests pytest