summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHan Mertens <hanmertens@outlook.com>2020-11-09 21:17:36 +0100
committerPatrice Clement <monsieurp@gentoo.org>2020-11-11 22:26:40 +0100
commit1f569f59422f100a5bd34cae4b85b2b7d8270ecc (patch)
treee13412147c912d2d9b6ac84e4f24f0c7ce2b83ed /dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
parentdev-python/pipenv: bump version to 2020.11.4. (diff)
downloadgentoo-1f569f59422f100a5bd34cae4b85b2b7d8270ecc.tar.gz
gentoo-1f569f59422f100a5bd34cae4b85b2b7d8270ecc.tar.bz2
gentoo-1f569f59422f100a5bd34cae4b85b2b7d8270ecc.zip
dev-python/uncertainties: add dev-pytohn/future as dependency.
Closes: https://bugs.gentoo.org/732832 Signed-off-by: Han Mertens <hanmertens@outlook.com> Closes: https://github.com/gentoo/gentoo/pull/18204 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild b/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
new file mode 100644
index 000000000000..0aff696ff8dd
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.1.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests nose
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}