summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-12 08:26:06 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-12 11:11:34 +0200
commit581236b5f97942840d11e1640c9f321779e39aea (patch)
tree6eaaab62529d76b44b349faedf73a18714fefc7a /dev-python/uncertainties
parentdev-python/hypothesis: Bump to 6.14.2 (diff)
downloadgentoo-581236b5f97942840d11e1640c9f321779e39aea.tar.gz
gentoo-581236b5f97942840d11e1640c9f321779e39aea.tar.bz2
gentoo-581236b5f97942840d11e1640c9f321779e39aea.zip
dev-python/uncertainties: Bump to 3.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/Manifest1
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.6.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
index 5b1991f62333..ccfe4295aeef 100644
--- a/dev-python/uncertainties/Manifest
+++ b/dev-python/uncertainties/Manifest
@@ -1 +1,2 @@
DIST uncertainties-3.1.4.tar.gz 148897 BLAKE2B 3e94b61ff6aac42a7910cafebee5b440541a020c58bc2ce402d0a056b5d278205f4a6556bf49073f5ded305cfa73ba7e9095e71d3963fd9b73e2e9e19ec360b5 SHA512 209ebbed1f9cf99e3263f6470b04fc737c6d34d878f7eb1d2a7df7e63d4d42b0460391a08f99d8fe09df8f7f0e1de8a8e6c2cbecaedc7f0373ab06d05fbeb955
+DIST uncertainties-3.1.6.tar.gz 158419 BLAKE2B 09582936a9b982efeee6cf3c99de568ebc820940ca2bfa1e4fd10edbcbd9447e7711158f8b98567a506d6c5a9ecf63b6e21d296c7f8d8dcbbaf4c2fb6a571355 SHA512 8835ed851d00bbe830770e57bc89ce57acf291e6cef2fca59897adb75e1e2de456da3631f73242ade20f567358b1d727b2b7f5df02e2f3e0cd8d861e81a6a211
diff --git a/dev-python/uncertainties/uncertainties-3.1.6.ebuild b/dev-python/uncertainties/uncertainties-3.1.6.ebuild
new file mode 100644
index 000000000000..96b4e0d8f983
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests nose
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}