summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-07 12:20:06 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-07 12:45:22 +0200
commit740f9378e01050cabb897fe592e65d911f8d5715 (patch)
treeadc00dd623051636267f476b724e0d51b8514835 /dev-python/uncertainties
parentnet-libs/libtorrent-rasterbar: enable logging by default (diff)
downloadgentoo-740f9378e01050cabb897fe592e65d911f8d5715.tar.gz
gentoo-740f9378e01050cabb897fe592e65d911f8d5715.tar.bz2
gentoo-740f9378e01050cabb897fe592e65d911f8d5715.zip
dev-python/uncertainties: Bump to 3.1.4
Closes: https://bugs.gentoo.org/657016 Closes: https://bugs.gentoo.org/701646 Closes: https://bugs.gentoo.org/719614 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/Manifest1
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
index d51deff0a09a..f86a0b6a3f51 100644
--- a/dev-python/uncertainties/Manifest
+++ b/dev-python/uncertainties/Manifest
@@ -1 +1,2 @@
DIST uncertainties-3.0.1.tar.gz 225752 BLAKE2B 6dc872d5617b8c4e9deda5a5a60492ae1eb0facd7f053f0799b3762831f9bad7da39726811feffa3630091e00dbedf89c296ed4e1b2b1f78399ed45663ea5339 SHA512 d4b2a905665c46224586f5f9702ad9e69580fc5afe8c6c045b04141fdc54e0c402cdee033ee0ee7055823b922bd33c732b3066453876509d45add15abf9d85f5
+DIST uncertainties-3.1.4.tar.gz 148897 BLAKE2B 3e94b61ff6aac42a7910cafebee5b440541a020c58bc2ce402d0a056b5d278205f4a6556bf49073f5ded305cfa73ba7e9095e71d3963fd9b73e2e9e19ec360b5 SHA512 209ebbed1f9cf99e3263f6470b04fc737c6d34d878f7eb1d2a7df7e63d4d42b0460391a08f99d8fe09df8f7f0e1de8a8e6c2cbecaedc7f0373ab06d05fbeb955
diff --git a/dev-python/uncertainties/uncertainties-3.1.4.ebuild b/dev-python/uncertainties/uncertainties-3.1.4.ebuild
new file mode 100644
index 000000000000..f1decac029b5
--- /dev/null
+++ b/dev-python/uncertainties/uncertainties-3.1.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for calculations with uncertainties"
+HOMEPAGE="https://pythonhosted.org/uncertainties/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests nose
+
+ppython_compile_all() {
+ if use doc; then
+ PYTHONPATH="${BUILD_DIR}"/lib esetup.py build_sphinx
+ fi
+}
+
+python_compile_all() {
+ use doc && "${PYTHON}" setup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/sphinx/html/. )
+ distutils-r1_python_install_all
+}