summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-25 21:10:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-25 21:10:49 +0300
commitfa343bc099d0f401b5a18af32c12caee25a9d787 (patch)
treec876cfa38181366cc451148e0d3eddad31b82da4 /dev-python/uncertainties
parentdev-python/uncertainties: make numpy optional dep (diff)
downloadgentoo-fa343bc099d0f401b5a18af32c12caee25a9d787.tar.gz
gentoo-fa343bc099d0f401b5a18af32c12caee25a9d787.tar.bz2
gentoo-fa343bc099d0f401b5a18af32c12caee25a9d787.zip
dev-python/uncertainties: use distutils_enable_sphinx for doc gen
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/uncertainties-3.1.6.ebuild12
1 files changed, 1 insertions, 11 deletions
diff --git a/dev-python/uncertainties/uncertainties-3.1.6.ebuild b/dev-python/uncertainties/uncertainties-3.1.6.ebuild
index 69090d5bc1f8..c7a176fb8e25 100644
--- a/dev-python/uncertainties/uncertainties-3.1.6.ebuild
+++ b/dev-python/uncertainties/uncertainties-3.1.6.ebuild
@@ -13,24 +13,14 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc"
RDEPEND="dev-python/future[${PYTHON_USEDEP}]"
BDEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/numpy[${PYTHON_USEDEP}] )
"
distutils_enable_tests nose
-
-python_compile_all() {
- use doc && "${PYTHON}" setup.py build_sphinx
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( build/sphinx/html/. )
- distutils-r1_python_install_all
-}
+distutils_enable_sphinx doc --no-autodoc
pkg_postinst() {
optfeature "numpy support" dev-python/numpy