summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-06-09 11:12:57 -0700
committerBrian Dolbec <dolsen@gentoo.org>2017-06-09 11:18:47 -0700
commit4a960fb44ce532c10ab51379aa7469e9bb174aeb (patch)
tree57d315b4cfca755bf7b38801570a6f283e5bf3c6 /dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
parentdev-python/xdis: Version bump (diff)
downloadgentoo-4a960fb44ce532c10ab51379aa7469e9bb174aeb.tar.gz
gentoo-4a960fb44ce532c10ab51379aa7469e9bb174aeb.tar.bz2
gentoo-4a960fb44ce532c10ab51379aa7469e9bb174aeb.zip
dev-python/uncompyle6: Version Bump
Package-Manager: Portage-2.3.6_p2, Repoman-2.3.2_p70
Diffstat (limited to 'dev-python/uncompyle6/uncompyle6-2.10.1.ebuild')
-rw-r--r--dev-python/uncompyle6/uncompyle6-2.10.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild b/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
new file mode 100644
index 000000000000..2e3cc7ae1c82
--- /dev/null
+++ b/dev-python/uncompyle6/uncompyle6-2.10.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python cross-version byte-code deparser"
+HOMEPAGE="https://github.com/rocky/python-uncompyle6/ https://pypi.python.org/pypi/uncompyle6"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/xdis-3.3.1
+ <dev-python/xdis-3.4.0
+ >=dev-python/spark-parser-1.6.1
+ <dev-python/spark-parser-1.7.0"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+# only run the recommended "make check" tests
+python_test() {
+ distutils_install_for_testing
+
+ PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
+ emake check || die "Tests failed under ${EPYTHON}"
+}