summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-06-29 18:48:58 +0200
committerJeroen Roovers <jer@gentoo.org>2017-06-29 19:07:24 +0200
commitd1594a2325e56dfe54638ad16f530e44ade0b8f5 (patch)
tree7054b84b4be4e1dc92c8c326d20b5d5dc8c77101 /dev-python/unidecode/unidecode-0.04.21.ebuild
parentapp-emulation/docker-machine: version bump to 0.12.0 (diff)
downloadgentoo-d1594a2325e56dfe54638ad16f530e44ade0b8f5.tar.gz
gentoo-d1594a2325e56dfe54638ad16f530e44ade0b8f5.tar.bz2
gentoo-d1594a2325e56dfe54638ad16f530e44ade0b8f5.zip
dev-python/unidecode: Version bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/unidecode/unidecode-0.04.21.ebuild')
-rw-r--r--dev-python/unidecode/unidecode-0.04.21.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-0.04.21.ebuild b/dev-python/unidecode/unidecode-0.04.21.ebuild
new file mode 100644
index 000000000000..7aee4702b2c5
--- /dev/null
+++ b/dev-python/unidecode/unidecode-0.04.21.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+MY_PN=Unidecode
+MY_P=${MY_PN}-${PV}
+
+inherit distutils-r1
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.python.org/pypi/Unidecode"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}