summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-28 19:59:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-28 20:32:54 +0200
commit71b1f624aec069bee76776ca7956c3dc9fc32dda (patch)
tree36464c57aa1d6bd117f6ff41f0c5d346354fbd7b /dev-python/unidecode/unidecode-1.3.5.ebuild
parentdev-python/iso8601: Bump to 1.1.0 (diff)
downloadgentoo-71b1f624aec069bee76776ca7956c3dc9fc32dda.tar.gz
gentoo-71b1f624aec069bee76776ca7956c3dc9fc32dda.tar.bz2
gentoo-71b1f624aec069bee76776ca7956c3dc9fc32dda.zip
dev-python/unidecode: Bump to 1.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unidecode/unidecode-1.3.5.ebuild')
-rw-r--r--dev-python/unidecode/unidecode-1.3.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/unidecode/unidecode-1.3.5.ebuild b/dev-python/unidecode/unidecode-1.3.5.ebuild
new file mode 100644
index 000000000000..737ca84c1ba9
--- /dev/null
+++ b/dev-python/unidecode/unidecode-1.3.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=Unidecode-${PV}
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.org/project/Unidecode/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest