summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-06 22:02:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-06 22:13:33 +0200
commit064a46f858dca0af4dfa2ff131af02731ab285d2 (patch)
tree6864a34d847abb0955caff4393d92205b96023ad /dev-python/unidecode
parentdev-python/markups: Bump to 3.1.2 (diff)
downloadgentoo-064a46f858dca0af4dfa2ff131af02731ab285d2.tar.gz
gentoo-064a46f858dca0af4dfa2ff131af02731ab285d2.tar.bz2
gentoo-064a46f858dca0af4dfa2ff131af02731ab285d2.zip
dev-python/unidecode: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unidecode')
-rw-r--r--dev-python/unidecode/Manifest1
-rw-r--r--dev-python/unidecode/unidecode-1.3.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/unidecode/Manifest b/dev-python/unidecode/Manifest
index ec0cac55feb2..49c3ec6dd1a4 100644
--- a/dev-python/unidecode/Manifest
+++ b/dev-python/unidecode/Manifest
@@ -1 +1,2 @@
DIST Unidecode-1.2.0.tar.gz 216042 BLAKE2B c63a192bfa726a9e91224e73a42236088de0b39f34f3f6404eec1c3adfe6512e843ce1f75dab32456ce6be4d938b0b8acfc1e6243c394dffff7d4d47d07d0905 SHA512 aedc16be1b676dbde7e45444e297be916b1ca2874a76f07316e2df3aff9687dcf73def24b2441e147c94641f4407cc745ac35937508e09c670f8aa1473977859
+DIST Unidecode-1.3.0.tar.gz 191814 BLAKE2B ca995b91d802eff3dc07b78359f73a5b44d0197ba522d43c7cbe36c85682c20e943214d671ac2203829196d472456f853ad0988d21fa2e568b13ef865932bed6 SHA512 98682ce5c844bfb74466d0c4c16cb74b358f50ce7fc8ca8dd56836d1b8745cb5c78692b8027ff9caf59394df6050ae2f36f888bb95ef8fc7c84cabe2a596b185
diff --git a/dev-python/unidecode/unidecode-1.3.0.ebuild b/dev-python/unidecode/unidecode-1.3.0.ebuild
new file mode 100644
index 000000000000..5a9d5f4cad04
--- /dev/null
+++ b/dev-python/unidecode/unidecode-1.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+MY_P=Unidecode-${PV}
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.org/project/Unidecode/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests setup.py