summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2021-04-25 17:02:26 -0400
committerBrian Dolbec <dolsen@gentoo.org>2021-04-25 17:13:25 -0400
commit2792e59853bfbdc48c02c3afb0083f085ba94c50 (patch)
tree3acb7361e68973f02a89bb7f07fc768c7affbe78 /dev-python/unidiff/unidiff-0.6.0.ebuild
parentpackage.mask: Last rite app-misc/logitech-applet (diff)
downloadgentoo-2792e59853bfbdc48c02c3afb0083f085ba94c50.tar.gz
gentoo-2792e59853bfbdc48c02c3afb0083f085ba94c50.tar.bz2
gentoo-2792e59853bfbdc48c02c3afb0083f085ba94c50.zip
dev-python/unidiff: New pkg, new dep of dev-util/buildbot
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
Diffstat (limited to 'dev-python/unidiff/unidiff-0.6.0.ebuild')
-rw-r--r--dev-python/unidiff/unidiff-0.6.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/unidiff/unidiff-0.6.0.ebuild b/dev-python/unidiff/unidiff-0.6.0.ebuild
new file mode 100644
index 000000000000..99713f3bca4b
--- /dev/null
+++ b/dev-python/unidiff/unidiff-0.6.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="Unified diff parsing/metadata extraction library"
+HOMEPAGE="https://github.com/matiasb/python-unidiff https://pypi.org/project/unidiff/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_tests unittest