summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-03-11 16:45:52 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-11 16:56:15 -0500
commit17292ba174cdfde36d042bf1cb50880f257e4028 (patch)
tree42567a24c3857e5e099618491477811b49caecf3 /dev-python/uritemplate/uritemplate-3.0.1.ebuild
parentdev-python/django-prometheus: 2.0.0 bump (diff)
downloadgentoo-17292ba174cdfde36d042bf1cb50880f257e4028.tar.gz
gentoo-17292ba174cdfde36d042bf1cb50880f257e4028.tar.bz2
gentoo-17292ba174cdfde36d042bf1cb50880f257e4028.zip
dev-python/uritemplate: 3.0.1 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/uritemplate/uritemplate-3.0.1.ebuild')
-rw-r--r--dev-python/uritemplate/uritemplate-3.0.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/uritemplate/uritemplate-3.0.1.ebuild b/dev-python/uritemplate/uritemplate-3.0.1.ebuild
new file mode 100644
index 000000000000..a4ea032e684f
--- /dev/null
+++ b/dev-python/uritemplate/uritemplate-3.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of RFC6570, URI Template"
+HOMEPAGE="https://pypi.org/project/uritemplate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 arm ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !<=dev-python/google-api-python-client-1.3"
+DEPEND="${RDEPEND}"