summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-30 16:48:46 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-30 19:05:38 +0100
commit8e567eaad7584c4757996db205f527e09b7cac47 (patch)
tree0cba02f0a9c45070ae1c6d2f53c433b26b94087b /dev-python/urllib3
parentdev-python/nose-exclude: Enable pypy3 (diff)
downloadgentoo-8e567eaad7584c4757996db205f527e09b7cac47.tar.gz
gentoo-8e567eaad7584c4757996db205f527e09b7cac47.tar.bz2
gentoo-8e567eaad7584c4757996db205f527e09b7cac47.zip
dev-python/urllib3: Enable pypy3
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/urllib3-1.19.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/urllib3/urllib3-1.19.ebuild b/dev-python/urllib3/urllib3-1.19.ebuild
index bebfc5e95678..162a683970b7 100644
--- a/dev-python/urllib3/urllib3-1.19.ebuild
+++ b/dev-python/urllib3/urllib3-1.19.ebuild
@@ -4,7 +4,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -97,7 +97,8 @@ python_test() {
# Failures still occur under py2.7.
# https://github.com/shazow/urllib3/issues/621
- [[ "${EPYTHON}" == pypy ]] && return
+ # FIXME: get tornado ported
+ [[ "${EPYTHON}" == pypy* ]] && return
nosetests -v \
--exclude test_headerdict \