summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-20 12:27:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-20 12:46:56 +0200
commitbbbf8d20a2d4f437c07b7c6519408bc98325b224 (patch)
tree5a89f4786826c7c22f6898db45efde1fcea4a751 /dev-python/urllib3
parentdev-python/chardet: Remove python2 (diff)
downloadgentoo-bbbf8d20a2d4f437c07b7c6519408bc98325b224.tar.gz
gentoo-bbbf8d20a2d4f437c07b7c6519408bc98325b224.tar.bz2
gentoo-bbbf8d20a2d4f437c07b7c6519408bc98325b224.zip
dev-python/urllib3: Remove python2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/urllib3-1.24.2-r1.ebuild (renamed from dev-python/urllib3/urllib3-1.24.2.ebuild)5
-rw-r--r--dev-python/urllib3/urllib3-1.25.10-r1.ebuild (renamed from dev-python/urllib3/urllib3-1.25.10.ebuild)10
2 files changed, 2 insertions, 13 deletions
diff --git a/dev-python/urllib3/urllib3-1.24.2.ebuild b/dev-python/urllib3/urllib3-1.24.2-r1.ebuild
index 82e560366169..e2c7aedf4805 100644
--- a/dev-python/urllib3/urllib3-1.24.2.ebuild
+++ b/dev-python/urllib3/urllib3-1.24.2-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -25,9 +25,6 @@ RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
>=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/ipaddress[${PYTHON_USEDEP}]
- ' -2)
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
diff --git a/dev-python/urllib3/urllib3-1.25.10.ebuild b/dev-python/urllib3/urllib3-1.25.10-r1.ebuild
index 911f80d2650d..e6ad8daf3d3d 100644
--- a/dev-python/urllib3/urllib3-1.25.10.ebuild
+++ b/dev-python/urllib3/urllib3-1.25.10-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -25,9 +25,6 @@ RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
>=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/ipaddress[${PYTHON_USEDEP}]
- ' -2)
brotli? ( dev-python/brotlipy[${PYTHON_USEDEP}] )
"
BDEPEND="
@@ -64,11 +61,6 @@ python_test() {
local -x CI=1
# FIXME: get tornado ported
case ${EPYTHON} in
- python2*)
- ewarn "Tests are being skipped for Python 2 in order to reduce the number"
- ewarn "of circular dependencies for Python 2 removal. Please test"
- ewarn "manually in a virtualenv."
- ;;
python3*)
pytest -vv || die "Tests fail with ${EPYTHON}"
;;