summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-24 22:05:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-24 22:07:17 +0100
commit1be681156ae9b3a2063a9c9c034e7eadce59a8b9 (patch)
tree786e8b7de7fb8cfa440fa4a250831d1bbc3916df /dev-python/utidylib/utidylib-0.6.ebuild
parentsys-kernel/genkernel: make pkgcheck happy (diff)
downloadgentoo-1be681156ae9b3a2063a9c9c034e7eadce59a8b9.tar.gz
gentoo-1be681156ae9b3a2063a9c9c034e7eadce59a8b9.tar.bz2
gentoo-1be681156ae9b3a2063a9c9c034e7eadce59a8b9.zip
dev-python/utidylib: Drop PYTHON_USEDEP from dev-python/sphinx
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/utidylib/utidylib-0.6.ebuild')
-rw-r--r--dev-python/utidylib/utidylib-0.6.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-python/utidylib/utidylib-0.6.ebuild b/dev-python/utidylib/utidylib-0.6.ebuild
index b37e9e1ddd2f..5e18aa363d3e 100644
--- a/dev-python/utidylib/utidylib-0.6.ebuild
+++ b/dev-python/utidylib/utidylib-0.6.ebuild
@@ -18,20 +18,20 @@ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
IUSE="doc test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- doc? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
test? ( || ( $(python_gen_useflags 'python2*' python3_6 python3_7) ) )
"
BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( $(python_gen_cond_dep 'dev-python/sphinx[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7) )
- test? (
- $(python_gen_cond_dep 'dev-python/flake8[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
- $(python_gen_cond_dep 'dev-python/pycodestyle[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
- $(python_gen_cond_dep 'dev-python/pyflakes[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
- $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
- $(python_gen_cond_dep 'dev-python/pytest-cov[${PYTHON_USEDEP}]' 'python2*' python3_6 python3_7)
- )
+ doc? ( dev-python/sphinx )
+ test? ( $(python_gen_cond_dep '
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ ' 'python2*' python3_6 python3_7
+ ) )
"
DEPEND="
dev-python/six[${PYTHON_USEDEP}]