summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-21 12:56:57 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-21 14:24:50 +0100
commit14cc0ebeef97aadd01785e4f34f6f1f6721dddb1 (patch)
treee08919494afcf7e0a7a5837ca467de66c56fcd27 /dev-python/uvicorn
parentdev-python/patiencediff: Bump to 0.2.8 (diff)
downloadgentoo-14cc0ebeef97aadd01785e4f34f6f1f6721dddb1.tar.gz
gentoo-14cc0ebeef97aadd01785e4f34f6f1f6721dddb1.tar.bz2
gentoo-14cc0ebeef97aadd01785e4f34f6f1f6721dddb1.zip
dev-python/uvicorn: Bump to 0.20.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.20.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index 2a0709a43f23..223a0d02e016 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,2 +1,3 @@
DIST uvicorn-0.18.3.gh.tar.gz 713216 BLAKE2B ba1fb1f2241fa3c23bc4115d335ef1c176937e8af5e33ae7d1e615271c94bc330ef5cb21d6bedd697ecb2a38798758ea47d5523ea6ee45295cf447e81503ff05 SHA512 a4983e7095f3596ac54557432a074eb8cae4c6dd579fabfe8b6c34606ba8258e6c0684c2e34e8019f2455fbfd1771f8c2c88bf8b01fc505abfae93655f61f032
DIST uvicorn-0.19.0.gh.tar.gz 713679 BLAKE2B ee83cd7d318b0e54bd2dc240b5bfe3874ef41933ba7e2376e8dd3bdce90387b3d253c02c16ef28bbb54435b2e666309769cd057fe703d4be498f3c0ef19532c0 SHA512 d030a0c5e61b5bec985fa1640a74bf5da1dfa1a48d0b3f758096eaff2e3bf1d1b3bee1c3a024f5960cafbf928e9ee94e285a8c24404e1c4b6b6aa29f0d4cb15a
+DIST uvicorn-0.20.0.gh.tar.gz 716073 BLAKE2B 7f1cf4808e985199d39e54e3563119cef1fe3af31361ad05a91278d32bc6f0dd741ad87f6073fbb720e9d9d4119fc8389b4e2feaaede665d8f68c56d56b37a17 SHA512 fa089da78dd7ce3cc02d83405e7db401e6055e947b80bf4abb0e3a4dce6575d97761f3bd6fcc253f3338caad5f797fc4f01bd40d833514d9cc0bcd0f072ad793
diff --git a/dev-python/uvicorn/uvicorn-0.20.0.ebuild b/dev-python/uvicorn/uvicorn-0.20.0.ebuild
new file mode 100644
index 000000000000..e69ff45423ec
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.20.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="
+ https://www.uvicorn.org/
+ https://github.com/encode/uvicorn/
+ https://pypi.org/project/uvicorn/
+"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ # need unpackaged httptools
+ "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
+ tests/protocols/test_http.py::test_fragmentation
+ )
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # TODO
+ EPYTEST_DESELECT+=(
+ tests/middleware/test_logging.py::test_running_log_using_fd
+ )
+ fi
+
+ local EPYTEST_IGNORE=()
+ # love from Rust world
+ if ! has_version "dev-python/watchfiles[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/supervisors/test_reload.py
+ )
+ fi
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}