summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-06-20 17:46:20 -0400
committerMike Gilbert <floppym@gentoo.org>2018-06-20 17:46:35 -0400
commit7559106d73eb9f57fdee1e50bfca158be6eba6a5 (patch)
tree58da5bd83dc803c30b8e95c26148700987ac4f19 /dev-python/vcrpy/vcrpy-1.11.1.ebuild
parentwww-client/chromium: update patch (diff)
downloadgentoo-7559106d73eb9f57fdee1e50bfca158be6eba6a5.tar.gz
gentoo-7559106d73eb9f57fdee1e50bfca158be6eba6a5.tar.bz2
gentoo-7559106d73eb9f57fdee1e50bfca158be6eba6a5.zip
dev-python/vcrpy: skip test requiring network access
Closes: https://bugs.gentoo.org/645514 Package-Manager: Portage-2.3.40_p15, Repoman-2.3.9_p247
Diffstat (limited to 'dev-python/vcrpy/vcrpy-1.11.1.ebuild')
-rw-r--r--dev-python/vcrpy/vcrpy-1.11.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/vcrpy/vcrpy-1.11.1.ebuild b/dev-python/vcrpy/vcrpy-1.11.1.ebuild
index b50e9d02784c..0bc4604553ed 100644
--- a/dev-python/vcrpy/vcrpy-1.11.1.ebuild
+++ b/dev-python/vcrpy/vcrpy-1.11.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -36,6 +36,10 @@ DEPEND="
dev-python/pytest-httpbin[${PYTHON_USEDEP}]
)"
+PATCHES=(
+ "${FILESDIR}"/vcrpy-skip-network-tests.patch
+)
+
python_test() {
py.test -vv -x tests/unit || die
}