summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 10:44:28 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 10:49:58 +0200
commitcad319b71be04dbcca31b448392e7e226602157d (patch)
tree2a5a2f5ead2be33f0a62fd5cba38a800bdff7b22 /dev-python/vcrpy/vcrpy-5.1.0.ebuild
parentdev-python/pytest-recording: New package, v0.13.0 (diff)
downloadgentoo-cad319b71be04dbcca31b448392e7e226602157d.tar.gz
gentoo-cad319b71be04dbcca31b448392e7e226602157d.tar.bz2
gentoo-cad319b71be04dbcca31b448392e7e226602157d.zip
dev-python/vcrpy: Enabe py3.12, fix tests
Closes: https://bugs.gentoo.org/912195 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vcrpy/vcrpy-5.1.0.ebuild')
-rw-r--r--dev-python/vcrpy/vcrpy-5.1.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/vcrpy/vcrpy-5.1.0.ebuild b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
index daa52ed9d3d6..0cc7495e8266 100644
--- a/dev-python/vcrpy/vcrpy-5.1.0.ebuild
+++ b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -36,6 +36,10 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}/${P}-py312.patch"
+)
+
distutils_enable_tests pytest
python_test() {
@@ -52,6 +56,10 @@ python_test() {
# broken by simplejson, doesn't seem important
# https://github.com/kevin1024/vcrpy/issues/751
tests/unit/test_serialize.py::test_serialize_binary_request
+ # new httpbin, sigh
+ # https://github.com/kevin1024/vcrpy/issues/761
+ tests/integration/test_basic.py::test_basic_json_use
+ tests/integration/test_register_persister.py::test_load_cassette_with_custom_persister
)
local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)