summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-02 12:53:11 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-02 13:05:34 +0200
commitf4f9802c2e10ad0d7f650ad142ad3e8850355093 (patch)
treea30c9f2b5c582600e52abb051dfdaf6a1ae079cf /dev-python/vcversioner/vcversioner-2.14.0.0.ebuild
parentdev-python/rfc3986: Version Bump (diff)
downloadgentoo-f4f9802c2e10ad0d7f650ad142ad3e8850355093.tar.gz
gentoo-f4f9802c2e10ad0d7f650ad142ad3e8850355093.tar.bz2
gentoo-f4f9802c2e10ad0d7f650ad142ad3e8850355093.zip
dev-python/vcversioner: Add pypy support
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/vcversioner/vcversioner-2.14.0.0.ebuild')
-rw-r--r--dev-python/vcversioner/vcversioner-2.14.0.0.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/dev-python/vcversioner/vcversioner-2.14.0.0.ebuild b/dev-python/vcversioner/vcversioner-2.14.0.0.ebuild
index 5638db247708..c2c33998e41d 100644
--- a/dev-python/vcversioner/vcversioner-2.14.0.0.ebuild
+++ b/dev-python/vcversioner/vcversioner-2.14.0.0.ebuild
@@ -4,15 +4,27 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="Use version control tags to discover version numbers"
-HOMEPAGE="https://github.com/habnabit/vcversioner"
+HOMEPAGE="https://github.com/habnabit/vcversioner https://pypi.python.org/pypi/vcversioner"
SRC_URI="mirror://pypi/v/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+# not included
+RESTRICT=test
+
+python_test() {
+ py.test || die
+}