summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-08-05 16:45:36 +0100
committerAmy Liffey <amynka@gentoo.org>2018-08-05 16:45:36 +0100
commit2a176db61970861ebd75e075d82ad1afdf1a9e27 (patch)
treef7312c935001ad8cfd38f50cad214983c6ea81e2 /dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild
parentsci-geosciences/merkaartor: fix plugins path (diff)
downloadgentoo-2a176db61970861ebd75e075d82ad1afdf1a9e27.tar.gz
gentoo-2a176db61970861ebd75e075d82ad1afdf1a9e27.tar.bz2
gentoo-2a176db61970861ebd75e075d82ad1afdf1a9e27.zip
dev-python/vdirsyncer: version bump 0.16.7
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild')
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild
new file mode 100644
index 000000000000..4f92360de59b
--- /dev/null
+++ b/dev-python/vdirsyncer/vdirsyncer-0.16.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="https://github.com/pimutils/vdirsyncer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-threading-0.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+ !=dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.1[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
+
+python_test() {
+ # skip tests needing servers running
+ local -x DAV_SERVER=skip
+ local -x REMOTESTORAGE_SERVER=skip
+ # pytest dies hard if the envvars do not have any value...
+ local -x CI=false
+ local -x DETERMINISTIC_TESTS=false
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}