summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-03-14 18:34:13 +0100
committerAmy Winston <amynka@gentoo.org>2016-03-14 18:34:13 +0100
commit77703e330c80ab47ea0e70186c8890df4c3285a3 (patch)
treee8ed37fd17243a1543f51ac3a074d3f1edcd6eb9 /dev-python/vdirsyncer/vdirsyncer-0.9.0.ebuild
parentapp-editors/nedit: security patch added (diff)
downloadgentoo-77703e330c80ab47ea0e70186c8890df4c3285a3.tar.gz
gentoo-77703e330c80ab47ea0e70186c8890df4c3285a3.tar.bz2
gentoo-77703e330c80ab47ea0e70186c8890df4c3285a3.zip
dev-python/vdirsyncer: version bump 0.9.0 bug #577296
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/vdirsyncer/vdirsyncer-0.9.0.ebuild')
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.9.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.9.0.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.9.0.ebuild
new file mode 100644
index 000000000000..9a69fa9bc3ef
--- /dev/null
+++ b/dev-python/vdirsyncer/vdirsyncer-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronize calendars and contacts"
+HOMEPAGE="https://github.com/untitaker/vdirsyncer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
+ dev-python/click-log[${PYTHON_USEDEP}]
+ dev-python/click-threading[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ !=dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ =dev-python/lxml-3.4.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.5.0[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )