summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2021-06-03 00:13:57 +0200
committerSam James <sam@gentoo.org>2021-06-02 21:52:07 +0000
commit8f2ab3f0b48b9a96dbba20e0906cd689af885e54 (patch)
tree861d1556af2f730702855e22223c239fc49ac9be /dev-python/vdirsyncer
parentdev-python/vdirsyncer: Fix my broken python3.9 bump (diff)
downloadgentoo-8f2ab3f0b48b9a96dbba20e0906cd689af885e54.tar.gz
gentoo-8f2ab3f0b48b9a96dbba20e0906cd689af885e54.tar.bz2
gentoo-8f2ab3f0b48b9a96dbba20e0906cd689af885e54.zip
dev-python/vdirsyncer: Remove the dysfunctional version
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Nils Freydank <holgersson@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/21095 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/vdirsyncer')
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
deleted file mode 100644
index 4bdf656d17f0..000000000000
--- a/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="sqlite"
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="Synchronize calendars and contacts"
-HOMEPAGE="https://github.com/pimutils/vdirsyncer"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-SLOT="0"
-
-PATCHES=( "${FILESDIR}/${P}-click-7-compat.patch" )
-
-RDEPEND="dev-python/click[${PYTHON_USEDEP}]
- >=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
- <dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
- dev-python/click-threading[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-toolbelt[${PYTHON_USEDEP}]
- dev-python/atomicwrites[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS.rst CHANGELOG.rst CONTRIBUTING.rst README.rst config.example )
-
-distutils_enable_tests pytest
-
-python_test() {
- # skip tests needing servers running
- local -x DAV_SERVER=skip
- local -x REMOTESTORAGE_SERVER=skip
- # pytest dies hard if the envvars do not have any value...
- local -x CI=false
- local -x DETERMINISTIC_TESTS=false
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}