summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-14 08:35:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-14 08:51:04 +0200
commitc1c9bbfa8de14612b05534eb862e02df8b2d6abe (patch)
tree3dfef878c620ed1e62f98385bd0406d0c2a40517 /dev-python/vdirsyncer
parentdev-python/vdirsyncer: Bump to 0.18.0 (diff)
downloadgentoo-c1c9bbfa8de14612b05534eb862e02df8b2d6abe.tar.gz
gentoo-c1c9bbfa8de14612b05534eb862e02df8b2d6abe.tar.bz2
gentoo-c1c9bbfa8de14612b05534eb862e02df8b2d6abe.zip
dev-python/vdirsyncer: Add python@ as co-maint.
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vdirsyncer')
-rw-r--r--dev-python/vdirsyncer/metadata.xml4
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.18.0.ebuild12
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-python/vdirsyncer/metadata.xml b/dev-python/vdirsyncer/metadata.xml
index 06fce01547f7..f42dda4bb8ac 100644
--- a/dev-python/vdirsyncer/metadata.xml
+++ b/dev-python/vdirsyncer/metadata.xml
@@ -4,6 +4,10 @@
<maintainer type="person">
<email>amynka@gentoo.org</email>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="github">pimutils/vdirsyncer</remote-id>
<remote-id type="pypi">vdirsyncer</remote-id>
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.18.0.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.18.0.ebuild
index 05fd220b6b81..d902fe2f289b 100644
--- a/dev-python/vdirsyncer/vdirsyncer-0.18.0.ebuild
+++ b/dev-python/vdirsyncer/vdirsyncer-0.18.0.ebuild
@@ -5,7 +5,6 @@ EAPI="7"
PYTHON_COMPAT=( python3_{8..9} )
PYTHON_REQ_USE="sqlite"
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -17,8 +16,6 @@ LICENSE="BSD"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
SLOT="0"
-PATCHES=( "${FILESDIR}/${PN}-0.16.8-click-7-compat.patch" )
-
RDEPEND="dev-python/click[${PYTHON_USEDEP}]
>=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
<dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
@@ -45,5 +42,12 @@ python_test() {
# pytest dies hard if the envvars do not have any value...
local -x CI=false
local -x DETERMINISTIC_TESTS=false
- epytest
+
+ local deselect=(
+ # test CA is too weak for modern python
+ tests/system/utils/test_main.py::test_request_ssl
+ tests/system/utils/test_main.py::test_request_ssl_fingerprints
+ )
+
+ epytest ${deselect[@]/#/--deselect }
}