summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2021-05-16 10:40:50 +0000
committerSam James <sam@gentoo.org>2021-06-01 13:03:07 +0000
commitd4b3d02583d2600c506bb602994f8d74ab66fe51 (patch)
tree9e1221b90db15609462729394c97b7bc7e39f2b8 /dev-python/vdirsyncer
parentdev-python/click-threading: Bump to EAPI=7 and python3_9 (diff)
downloadgentoo-d4b3d02583d2600c506bb602994f8d74ab66fe51.tar.gz
gentoo-d4b3d02583d2600c506bb602994f8d74ab66fe51.tar.bz2
gentoo-d4b3d02583d2600c506bb602994f8d74ab66fe51.zip
dev-python/vdirsyncer: Bump to EAPI=7 and python3_9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/vdirsyncer')
-rw-r--r--dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild b/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
index 75a4bd75e520..4bdf656d17f0 100644
--- a/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
+++ b/dev-python/vdirsyncer/vdirsyncer-0.16.8.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="sqlite"
DISTUTILS_USE_SETUPTOOLS=rdepend
@@ -19,17 +19,17 @@ SLOT="0"
PATCHES=( "${FILESDIR}/${P}-click-7-compat.patch" )
-RDEPEND=">=dev-python/click-5.0[${PYTHON_USEDEP}]
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]
>=dev-python/click-log-0.3.0[${PYTHON_USEDEP}]
<dev-python/click-log-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/click-threading-0.2[${PYTHON_USEDEP}]
- >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
- >=dev-python/requests-toolbelt-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/atomicwrites-0.1.7[${PYTHON_USEDEP}]"
+ dev-python/click-threading[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/atomicwrites[${PYTHON_USEDEP}]"
BDEPEND="${RDEPEND}
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
- >=dev-python/hypothesis-5.0.0[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/pytest-localserver[${PYTHON_USEDEP}]
dev-python/pytest-subtesthack[${PYTHON_USEDEP}]
)"