summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-05 18:03:09 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-05 18:03:53 +0200
commit9643011b2b717a542a67cf39a138bbd3c4ea1246 (patch)
treec0949739d84c7c47ce6cf0a2fb2ebbb19174d422 /dev-python/versioneer
parentdev-python/kiwisolver: Port to py39 (diff)
downloadgentoo-9643011b2b717a542a67cf39a138bbd3c4ea1246.tar.gz
gentoo-9643011b2b717a542a67cf39a138bbd3c4ea1246.tar.bz2
gentoo-9643011b2b717a542a67cf39a138bbd3c4ea1246.zip
dev-python/versioneer: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/versioneer')
-rw-r--r--dev-python/versioneer/versioneer-0.18-r1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-python/versioneer/versioneer-0.18-r1.ebuild b/dev-python/versioneer/versioneer-0.18-r1.ebuild
index 7836f1d23a3f..38d6b48aa164 100644
--- a/dev-python/versioneer/versioneer-0.18-r1.ebuild
+++ b/dev-python/versioneer/versioneer-0.18-r1.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -31,8 +32,8 @@ PATCHES=(
python_test() {
esetup.py make_versioneer
- git config --global user.email "you@example.com"
- git config --global user.name "Your Name"
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
${PYTHON} test/git/test_git.py -v || die
}