summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-23 07:50:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-23 07:50:42 +0200
commit7b071a18f1ca0d4657b4d1774e971081ba9279c4 (patch)
treebc38681b8d58fb39fd7072b0f2e42e98cc2ba4aa /dev-python/versioningit
parentdev-python/sqlglot: Bump to 18.7.0 (diff)
downloadgentoo-7b071a18f1ca0d4657b4d1774e971081ba9279c4.tar.gz
gentoo-7b071a18f1ca0d4657b4d1774e971081ba9279c4.tar.bz2
gentoo-7b071a18f1ca0d4657b4d1774e971081ba9279c4.zip
dev-python/versioningit: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/versioningit')
-rw-r--r--dev-python/versioningit/Manifest1
-rw-r--r--dev-python/versioningit/versioningit-2.2.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/versioningit/Manifest b/dev-python/versioningit/Manifest
index ef9f41e922cf..fb7650d8fb03 100644
--- a/dev-python/versioningit/Manifest
+++ b/dev-python/versioningit/Manifest
@@ -1 +1,2 @@
DIST versioningit-2.2.0.tar.gz 742936 BLAKE2B 05bfebce378947a9196b4bd90495dc8f89fa9b79b99e5a4423ff39df77f0353125ba5f2deec1e685feacb6fbb8ee896fd1f18155b985f803be4d21e885689128 SHA512 9169bd04c29937a5d913dfa4951affe9d01f21f513fb6f704bdd65f44c91dd47c366169fd50aecc938992cb32b6cac835359b1dc9a6b431b8b5371125564791e
+DIST versioningit-2.2.1.tar.gz 743942 BLAKE2B f0f84b2323cdeac79144d842bbebfc196aecb35752da4dc0e343a709fc539eba50f33079dc652e95dc06bda8ddb761b5a68179b50f533434aafd7d4b1263af63 SHA512 9ec8d4cf26392fd3bfd29d5c3e573a6af8e6a42c6aff1d0f9dbf68a17b667c55859d64d91d5715bf232f4eea22a6f300cbfc6da2be8364186c23b5023fa0e6ad
diff --git a/dev-python/versioningit/versioningit-2.2.1.ebuild b/dev-python/versioningit/versioningit-2.2.1.ebuild
new file mode 100644
index 000000000000..8f37d86f8d91
--- /dev/null
+++ b/dev-python/versioningit/versioningit-2.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A setuptools plugin for versioning based on git tags"
+HOMEPAGE="
+ https://github.com/jwodder/versioningit/
+ https://pypi.org/project/versioningit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/tomli-3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Tries to do wheel/pip installs
+ test/test_end2end.py
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/-cov/d' tox.ini || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest -p no:pytest-describe
+}