summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-24 09:24:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-24 10:00:08 +0200
commitf2cdb1f1a00237b79b1daa43c34e7a6b3830f134 (patch)
treea6aca4972c580e5269e66486e7b0cdc5eb4158e0 /dev-python/virtualenv/virtualenv-20.0.23.ebuild
parentdev-python/pytest-asyncio: Bump to 0.14.0 (diff)
downloadgentoo-f2cdb1f1a00237b79b1daa43c34e7a6b3830f134.tar.gz
gentoo-f2cdb1f1a00237b79b1daa43c34e7a6b3830f134.tar.bz2
gentoo-f2cdb1f1a00237b79b1daa43c34e7a6b3830f134.zip
dev-python/virtualenv: Apply test deps for impls running tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/virtualenv/virtualenv-20.0.23.ebuild')
-rw-r--r--dev-python/virtualenv/virtualenv-20.0.23.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/dev-python/virtualenv/virtualenv-20.0.23.ebuild b/dev-python/virtualenv/virtualenv-20.0.23.ebuild
index a7fac541d104..6c1825d6e7d5 100644
--- a/dev-python/virtualenv/virtualenv-20.0.23.ebuild
+++ b/dev-python/virtualenv/virtualenv-20.0.23.ebuild
@@ -40,23 +40,24 @@ RDEPEND="
' -2 python3_6 pypy3)"
# coverage is used somehow magically in virtualenv, maybe it actually
# tests something useful
-BDEPEND="${RDEPEND}
+BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
- dev-python/coverage[${PYTHON_USEDEP}]
- >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
+ ${RDEPEND}
$(python_gen_cond_dep '
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/pip-20.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.3.4[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
>=dev-python/packaging-20.0[${PYTHON_USEDEP}]
- ' -3)
+ ' 'python3*')
)"
distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme \
dev-python/towncrier
-distutils_enable_tests pytest
src_prepare() {
# we don't have xonsh