summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-01 12:51:28 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-01 16:44:20 +0100
commita00188be0bad6b01051f84ddbe1ea8aac6fa1e66 (patch)
tree1e77cd1334c92c924ac36b545d7ac69462f5016a /dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
parentdev-python/mimeparse: Version Bump (diff)
downloadgentoo-a00188be0bad6b01051f84ddbe1ea8aac6fa1e66.tar.gz
gentoo-a00188be0bad6b01051f84ddbe1ea8aac6fa1e66.tar.bz2
gentoo-a00188be0bad6b01051f84ddbe1ea8aac6fa1e66.zip
dev-python/virtualenvwrapper: Version Bump
Shorten DESCRIPTION Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild')
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
new file mode 100644
index 000000000000..a0cc30d34d43
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="
+ http://www.doughellmann.com/projects/virtualenvwrapper
+ https://pypi.python.org/pypi/virtualenvwrapper"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
+RESTRICT=test
+
+RDEPEND="
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.15-r1[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+# Keep just in case
+src_prepare() {
+ sed -e 's:-o shwordsplit::' -i tests/run_tests || die
+}
+
+python_test() {
+ bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
+}