summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-03 00:03:14 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-04 21:00:25 +0200
commitcb3557ce7197a94c8ac70af71ce1ef28e7ba494a (patch)
treeafe6b9c4290dce6d631b5c58f256762205db9bce /dev-python/visitor/visitor-0.1.3-r1.ebuild
parentapp-misc/uptimed: Stabilize 0.4.2 amd64, #738288 (diff)
downloadgentoo-cb3557ce7197a94c8ac70af71ce1ef28e7ba494a.tar.gz
gentoo-cb3557ce7197a94c8ac70af71ce1ef28e7ba494a.tar.bz2
gentoo-cb3557ce7197a94c8ac70af71ce1ef28e7ba494a.zip
dev-python/visitor: add Python 3.8 and 3.9 support
Also switch to distutils_enable_tests and remove explicit dependency on setuptools. Package-Manager: Portage-3.0.3, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/visitor/visitor-0.1.3-r1.ebuild')
-rw-r--r--dev-python/visitor/visitor-0.1.3-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/visitor/visitor-0.1.3-r1.ebuild b/dev-python/visitor/visitor-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..2432bb2c6c8e
--- /dev/null
+++ b/dev-python/visitor/visitor-0.1.3-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tiny pythonic visitor implementation"
+HOMEPAGE="https://github.com/mbr/visitor"
+# PyPI tarballs don't include tests
+# https://github.com/mbr/visitor/pull/2
+SRC_URI="https://github.com/mbr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest