summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-13 22:51:10 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-14 16:58:19 +0300
commita3c6e4fe5bfe6cab2e07484b82593db1ad26d0cd (patch)
tree1d21265168d08c237f79aac28a7855f5c6f47b48 /dev-python/vncdotool
parentdev-python/vncdotool: add github upstream metadata (diff)
downloadgentoo-a3c6e4fe5bfe6cab2e07484b82593db1ad26d0cd.tar.gz
gentoo-a3c6e4fe5bfe6cab2e07484b82593db1ad26d0cd.tar.bz2
gentoo-a3c6e4fe5bfe6cab2e07484b82593db1ad26d0cd.zip
dev-python/vncdotool: enable py3.10, fix deps
fix DISTUTILS_USE_SETUPTOOLS The reason tests fail is that the package expects the examples from net-libs/libvncserver. But those aren't intended to be installed (CMake skips them from install). By manually configuring and manually calling ninja build example, and manually installing, the test suite can be ran and work. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/vncdotool')
-rw-r--r--dev-python/vncdotool/vncdotool-0.13.0.ebuild12
-rw-r--r--dev-python/vncdotool/vncdotool-1.0.0.ebuild10
2 files changed, 9 insertions, 13 deletions
diff --git a/dev-python/vncdotool/vncdotool-0.13.0.ebuild b/dev-python/vncdotool/vncdotool-0.13.0.ebuild
index 5a1b894b8cc8..122de63db2a3 100644
--- a/dev-python/vncdotool/vncdotool-0.13.0.ebuild
+++ b/dev-python/vncdotool/vncdotool-0.13.0.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Command line VNC client"
@@ -16,8 +14,9 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-# No clue why this happens:
+# A lot of errors such as the following appear
# pexpect.exceptions.ExceptionPexpect: The command was not found or was not executable: vncev.
+# to install those, a manual compile and install of examples from net-libs/libvncserver is needed
RESTRICT="test"
BDEPEND="test? (
@@ -30,8 +29,7 @@ BDEPEND="test? (
dev-python/tox[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
)"
-
-DEPEND="
+RDEPEND="
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/twisted[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
diff --git a/dev-python/vncdotool/vncdotool-1.0.0.ebuild b/dev-python/vncdotool/vncdotool-1.0.0.ebuild
index de7a237c2740..122de63db2a3 100644
--- a/dev-python/vncdotool/vncdotool-1.0.0.ebuild
+++ b/dev-python/vncdotool/vncdotool-1.0.0.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Command line VNC client"
@@ -16,8 +14,9 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-# No clue why this happens:
+# A lot of errors such as the following appear
# pexpect.exceptions.ExceptionPexpect: The command was not found or was not executable: vncev.
+# to install those, a manual compile and install of examples from net-libs/libvncserver is needed
RESTRICT="test"
BDEPEND="test? (
@@ -30,8 +29,7 @@ BDEPEND="test? (
dev-python/tox[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
)"
-
-DEPEND="
+RDEPEND="
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/twisted[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]