summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-03-21 02:07:06 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-03-21 02:07:44 +0700
commit9dbd6bfe54386bf7a68e0724ddb2eeb9e309cd1d (patch)
tree4c3aeec1b21cd89fb26def544f5b9410eec21fb8 /dev-python/vpython/vpython-7.4.2.ebuild
parentwww-apps/agendav: version bump, bug #650922 (diff)
downloadgentoo-9dbd6bfe54386bf7a68e0724ddb2eeb9e309cd1d.tar.gz
gentoo-9dbd6bfe54386bf7a68e0724ddb2eeb9e309cd1d.tar.bz2
gentoo-9dbd6bfe54386bf7a68e0724ddb2eeb9e309cd1d.zip
dev-python/vpython: initial import
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/vpython/vpython-7.4.2.ebuild')
-rw-r--r--dev-python/vpython/vpython-7.4.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/vpython/vpython-7.4.2.ebuild b/dev-python/vpython/vpython-7.4.2.ebuild
new file mode 100644
index 000000000000..f5ba2ba317a7
--- /dev/null
+++ b/dev-python/vpython/vpython-7.4.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="VPython for Jupyter notebook"
+HOMEPAGE="http://www.vpython.org/ https://pypi.python.org/pypi/vpython/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ dev-python/jupyter[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"