summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2018-11-09 16:51:36 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2018-11-09 17:19:47 +0300
commit63c721459539e32c68c21a488bded082692b80d9 (patch)
tree499bf1f8a84b082b1c243e5c51430bf6b6ed98c4 /dev-python/waitress
parentAdd ppc32 17.0 profiles for musl/uclibc [+ hardened] (diff)
downloadgentoo-63c721459539e32c68c21a488bded082692b80d9.tar.gz
gentoo-63c721459539e32c68c21a488bded082692b80d9.tar.bz2
gentoo-63c721459539e32c68c21a488bded082692b80d9.zip
dev-python/waitress: eapi7 + py3_7
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'dev-python/waitress')
-rw-r--r--dev-python/waitress/waitress-1.0.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/waitress/waitress-1.0.2-r1.ebuild b/dev-python/waitress/waitress-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..934166e9bfc4
--- /dev/null
+++ b/dev-python/waitress/waitress-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="https://docs.pylonsproject.org/projects/waitress/en/latest/
+ https://pypi.org/project/waitress/
+ https://github.com/Pylons/waitress"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}