summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-17 07:56:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-17 08:27:56 +0200
commit88951ddad7ffccfbe20069e077fcb13e512aa81b (patch)
tree48c7e61e584632eaf50b73f8d3ee7eaa22281ebe /dev-python/wand
parentdev-python/pikepdf: Bump to 5.4.0 (diff)
downloadgentoo-88951ddad7ffccfbe20069e077fcb13e512aa81b.tar.gz
gentoo-88951ddad7ffccfbe20069e077fcb13e512aa81b.tar.bz2
gentoo-88951ddad7ffccfbe20069e077fcb13e512aa81b.zip
dev-python/wand: Bump to 0.6.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wand')
-rw-r--r--dev-python/wand/Manifest1
-rw-r--r--dev-python/wand/wand-0.6.8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
index 17e4557237c9..ccc377e34f8d 100644
--- a/dev-python/wand/Manifest
+++ b/dev-python/wand/Manifest
@@ -1 +1,2 @@
DIST Wand-0.6.7.tar.gz 11686093 BLAKE2B 58abbdc22eb1603ed42e2e2473c0ed2b9026c9c0a499bb885512b56ecf01fb4ffe450979808bba2b4c4466994f86bea9a9c0ced216f8338c845b96a755f39c9f SHA512 e79ecb909f6ad7b3ddae217bb7b27f3c010d22a40eb99866e2a6eb07346000acbead280176e3352da13c20b68a341c751c55d6203bef7968522c8dbcfcab0b06
+DIST Wand-0.6.8.tar.gz 11884527 BLAKE2B 45784abf55682d8b5e101cc4fc93f0492f9275a2805f06dbda2d98e28c6359c7df84fd7870b12348c0a6c513ae3f2bafba61a00020a41263d6a91fd67d9ce682 SHA512 111eef211edd8d5a6c825f0b455db5510c91b43852165934dbab36a9cdeea7e920987c98d975fb8c7f82ac19f20867c0ed5c8c1e2f9dd9467bc30931b4a03dd1
diff --git a/dev-python/wand/wand-0.6.8.ebuild b/dev-python/wand/wand-0.6.8.ebuild
new file mode 100644
index 000000000000..753e731d2674
--- /dev/null
+++ b/dev-python/wand/wand-0.6.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="
+ https://docs.wand-py.org/
+ https://github.com/emcconville/wand/
+ https://pypi.org/project/Wand/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-gfx/imagemagick
+"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ epytest --skip-pdf
+}