summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-21 07:37:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-21 09:48:16 +0200
commit361ac6d14b83aaf860eaf9810ad22d11acab4674 (patch)
treece08dbd5fff138e0b2d5a25f3b833150f37f45f9 /dev-python/watchfiles
parentdev-python/jupyterlab_server: Remove old (diff)
downloadgentoo-361ac6d14b83aaf860eaf9810ad22d11acab4674.tar.gz
gentoo-361ac6d14b83aaf860eaf9810ad22d11acab4674.tar.bz2
gentoo-361ac6d14b83aaf860eaf9810ad22d11acab4674.zip
dev-python/watchfiles: Bump to 0.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/watchfiles')
-rw-r--r--dev-python/watchfiles/Manifest1
-rw-r--r--dev-python/watchfiles/watchfiles-0.18.0.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/watchfiles/Manifest b/dev-python/watchfiles/Manifest
index 48d8d85f19fc..fbf6ac98e6b4 100644
--- a/dev-python/watchfiles/Manifest
+++ b/dev-python/watchfiles/Manifest
@@ -39,6 +39,7 @@ DIST unindent-0.1.8.crate 8326 BLAKE2B 3123c6b540b152d89cc7a9a76ff1315549f973c6a
DIST walkdir-2.3.2.crate 23516 BLAKE2B 473f2b51aafd6ac17e5c3da8d545d179b31486b3a65ab39fbd8bd7fbb2ebcc24bebf01781200a26a68f0b1cb464f5763a919aead3b03eba5a7e1be6efec5500b SHA512 6c44071354faf37720ec4117ded34c8d530489542ee107ac26a7a56ef4a882b9003e22e84f1d61f6078643521343e35aa1f7b57c838779e78e5937a667bf82da
DIST wasi-0.11.0+wasi-snapshot-preview1.crate 28131 BLAKE2B fe501889f25d65e2d032f885cc50c4f8bf7dd70fd5cbc438de349838370d8699e9627b0a4fc76030ea9fe6d508f41d0c9928a875fdbc47e73bfb17241cf7b155 SHA512 043500ab28cd9cb779475255da5d109ebab7fccca72b64873dc28d77bc5a157ba8d96b9e8f05223b5b36c7089bb7b4ba87657fc69bac16b78972f897294a865f
DIST watchfiles-0.17.0.gh.tar.gz 42487 BLAKE2B 9e50c1d2bea174754c393090a5ff07a92067af76ca17d1c4a058e27a082fec8347dd42e23178a319f8644f87f800174acf3f0db72dd35becdbb21d3ef425df5c SHA512 db39bf6c56d0af93807665aef8d96ed4331ff8a9d2a24ddd2b489ab5501ca3f5b33bd5cfbde2a33089622247d8b7f5ec91566f911ca564b812537b02be3ed2b2
+DIST watchfiles-0.18.0.gh.tar.gz 43563 BLAKE2B e8af967ee9499571d2f8a597ab2174b1be5d2e4c3cd61a63a5c02eb5614846084e446f2759534e9b35c0dfe2bf18992ef6aaccec009f7c57692c8b3b3014a1a4 SHA512 1cccf458ffa643a675e2e257e5074275e5f9c533743957bd7b58b3576ac47cca849e9ef219e40c9eccb854a6b8331bd3afa43bee8cf27b95ea6a4c2dbbaa97c0
DIST winapi-0.3.9.crate 1200382 BLAKE2B cb5799749ccd935ea2d7068d953cecf19f543d9db7dc16ad4584bb7005373ada34937a3ced7225544d8bc765da599911c7a3190efefb3a25b7c1bb7123b4f673 SHA512 ff8b7b78065f3d8999ec03c725a0460ebc059771bf071c7a3df3f0ecd733edf3b0a2450024d4e24e1aedddaecd9038ce1376c0d8bbf45132068cf45cf4a53a97
DIST winapi-i686-pc-windows-gnu-0.4.0.crate 2918815 BLAKE2B 4d357e4d30f9552972170d65b9a5358b69c46a3e772fe05efc22f3d4ffc1caeeaad7aacdc7abd503a7ad0545f8bd7d22bf351dcb6df76f812fa4d45c34d65df0 SHA512 a672ccefd0730a8166fef1d4e39f9034d9ae426a3f5e28d1f4169fa5c5790767693f281d890e7804773b34acdb0ae1febac33cde8c50c0044a5a6152c7209ec2
DIST winapi-util-0.1.5.crate 10164 BLAKE2B fc800aceae5249a858c806c3e969ef2545766099872d856ebee51c883d9acf1122278db9607d50ca53eac351502b700fd2463900932d342240f97f683d517963 SHA512 7baeb661f397c4693dfa001fdc774b323c51a7c55caad40f2de5112a1cefd1d6151e3df41fa4ee193460a5905917c83d2b1de5fa10b4bd014ad96690af95c0fd
diff --git a/dev-python/watchfiles/watchfiles-0.18.0.ebuild b/dev-python/watchfiles/watchfiles-0.18.0.ebuild
new file mode 100644
index 000000000000..ab7b96182857
--- /dev/null
+++ b/dev-python/watchfiles/watchfiles-0.18.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=maturin
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+CRATES="
+ autocfg-1.1.0
+ bitflags-1.3.2
+ cfg-if-1.0.0
+ crossbeam-channel-0.5.4
+ crossbeam-utils-0.8.8
+ filetime-0.2.16
+ fsevent-sys-4.1.0
+ indoc-1.0.4
+ inotify-0.9.6
+ inotify-sys-0.1.5
+ kqueue-1.0.5
+ kqueue-sys-1.0.3
+ lazy_static-1.4.0
+ libc-0.2.124
+ lock_api-0.4.7
+ log-0.4.16
+ mio-0.8.2
+ miow-0.3.7
+ notify-5.0.0
+ ntapi-0.3.7
+ once_cell-1.10.0
+ parking_lot-0.12.0
+ parking_lot_core-0.9.2
+ proc-macro2-1.0.37
+ pyo3-0.16.4
+ pyo3-build-config-0.16.4
+ pyo3-ffi-0.16.4
+ pyo3-macros-0.16.4
+ pyo3-macros-backend-0.16.4
+ quote-1.0.18
+ redox_syscall-0.2.13
+ same-file-1.0.6
+ scopeguard-1.1.0
+ smallvec-1.8.0
+ syn-1.0.91
+ target-lexicon-0.12.3
+ unicode-xid-0.2.2
+ unindent-0.1.8
+ walkdir-2.3.2
+ wasi-0.11.0+wasi-snapshot-preview1
+ winapi-0.3.9
+ winapi-i686-pc-windows-gnu-0.4.0
+ winapi-util-0.1.5
+ winapi-x86_64-pc-windows-gnu-0.4.0
+ windows-sys-0.34.0
+ windows_aarch64_msvc-0.34.0
+ windows_i686_gnu-0.34.0
+ windows_i686_msvc-0.34.0
+ windows_x86_64_gnu-0.34.0
+ windows_x86_64_msvc-0.34.0
+"
+
+inherit cargo distutils-r1
+
+DESCRIPTION="Simple, modern file watching and code reload in Python"
+HOMEPAGE="
+ https://pypi.org/project/watchfiles/
+ https://github.com/samuelcolvin/watchfiles/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/watchfiles/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ $(cargo_crate_uris ${CRATES})
+"
+
+LICENSE="MIT"
+# crates
+LICENSE+=" Apache-2.0 Apache-2.0-with-LLVM-exceptions Artistic-2 BSD"
+LICENSE+=" CC0-1.0 ISC MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/anyio-3*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-rust[${PYTHON_USEDEP}]
+ test? (
+ dev-python/dirty-equals[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+# enjoy Rust
+QA_FLAGS_IGNORED=".*/_rust_notify.*"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # fix version number
+ sed -i -e "/^version/s:0\.0\.0:${PV}:" Cargo.toml || die
+}
+
+python_test() {
+ rm -rf watchfiles || die
+ epytest
+}