summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:54:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:36 +0100
commit62d08037e30d859a765968927e2dfe57cb87c137 (patch)
tree7659fb80966aaf565c76ad7886ca779ace876185 /dev-python/wcag-contrast-ratio
parentdev-python/unittest-or-fail: Switch to PEP 517 build (diff)
downloadgentoo-62d08037e30d859a765968927e2dfe57cb87c137.tar.gz
gentoo-62d08037e30d859a765968927e2dfe57cb87c137.tar.bz2
gentoo-62d08037e30d859a765968927e2dfe57cb87c137.zip
dev-python/wcag-contrast-ratio: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wcag-contrast-ratio')
-rw-r--r--dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild
new file mode 100644
index 000000000000..bd6b2dc29f65
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A library for computing contrast ratios, as required by WCAG 2.0"
+HOMEPAGE="
+ https://github.com/gsnedders/wcag-contrast-ratio/
+ https://pypi.org/project/wcag-contrast-ratio/"
+SRC_URI="
+ https://github.com/gsnedders/wcag-contrast-ratio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}