summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/wcsaxes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/wcsaxes')
-rw-r--r--dev-python/wcsaxes/Manifest1
-rw-r--r--dev-python/wcsaxes/metadata.xml11
-rw-r--r--dev-python/wcsaxes/wcsaxes-0.3.ebuild46
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/wcsaxes/Manifest b/dev-python/wcsaxes/Manifest
new file mode 100644
index 000000000000..df3441cbc88b
--- /dev/null
+++ b/dev-python/wcsaxes/Manifest
@@ -0,0 +1 @@
+DIST wcsaxes-0.3.tar.gz 773984 SHA256 012861678afa3c05700c4dd94a73bbd0534dae7ef8d9dc215fb01d6e5a60477f SHA512 597494609e2add782dcf84a6163b7093d1a467ffb6321d6d25064f9f87dcb0f7e5e076818b0707b9f10d0894a26ce240cda9598f035364832efe57d6ec51d76a WHIRLPOOL 1d05ce40460a2477c43107f33a68de08cdeb66ee395d3311ee74c9e7d354b675584f3e5d79ea91303a1808ab767df6f54bb5c65993009edfa67b416057c459fe
diff --git a/dev-python/wcsaxes/metadata.xml b/dev-python/wcsaxes/metadata.xml
new file mode 100644
index 000000000000..6ec9ee7ad1a1
--- /dev/null
+++ b/dev-python/wcsaxes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-astronomy</herd>
+ <longdescription lang="en">
+ Framework for plotting astronomical and geospatial data
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">wcsaxes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wcsaxes/wcsaxes-0.3.ebuild b/dev-python/wcsaxes/wcsaxes-0.3.ebuild
new file mode 100644
index 000000000000..ffa134306889
--- /dev/null
+++ b/dev-python/wcsaxes/wcsaxes-0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for plotting astronomical and geospatial data"
+HOMEPAGE="http://wcsaxes.readthedocs.org https://pypi.python.org/pypi/wcsaxes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile() {
+ distutils-r1_python_compile --use-system-libraries --offline
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx --offline
+}
+
+python_test() {
+ esetup.py --offline test
+}
+
+python_install() {
+ distutils-r1_python_install --offline
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/ )
+ distutils-r1_python_install_all --offline
+}