summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-21 11:05:57 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-21 15:12:24 +0200
commit4caacdaea783657cb8d4ca50b5471be8d1e6ed56 (patch)
tree455f88b349b2ff56187c544410b468d2be2d93b3 /dev-python/wcwidth/wcwidth-0.1.7.ebuild
parentmedia-libs/libmypaint: Disable gold linker (bug #589266) (diff)
downloadgentoo-4caacdaea783657cb8d4ca50b5471be8d1e6ed56.tar.gz
gentoo-4caacdaea783657cb8d4ca50b5471be8d1e6ed56.tar.bz2
gentoo-4caacdaea783657cb8d4ca50b5471be8d1e6ed56.zip
dev-python/wcwidth: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/wcwidth/wcwidth-0.1.7.ebuild')
-rw-r--r--dev-python/wcwidth/wcwidth-0.1.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/wcwidth/wcwidth-0.1.7.ebuild b/dev-python/wcwidth/wcwidth-0.1.7.ebuild
new file mode 100644
index 000000000000..bbc123d1e92a
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.1.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="https://pypi.python.org/pypi/wcwidth/ https://github.com/jquast/wcwidth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v -rs --strict wcwidth/tests || die
+}