summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 05:26:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 05:44:10 +0100
commit68c01eb05076338a23e50fe2ebad04012689a008 (patch)
treead0260f4329202dbdd6408aea95f6e6f9f34d0c4 /dev-python/wcwidth
parentdev-python/sphinx-gallery: Bump to 0.15.0 (diff)
downloadgentoo-68c01eb05076338a23e50fe2ebad04012689a008.tar.gz
gentoo-68c01eb05076338a23e50fe2ebad04012689a008.tar.bz2
gentoo-68c01eb05076338a23e50fe2ebad04012689a008.zip
dev-python/wcwidth: Bump to 0.2.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest1
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.11.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index fda859daf7c8..18695f193f21 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -1,3 +1,4 @@
DIST wcwidth-0.2.10.gh.tar.gz 92276 BLAKE2B 69347446b6571feb68871a6195bfe6718f23d8a21332cda839bb41f2a540d222265065a1194e26d22a166d1d90fb4d5237703af96a8f1737c2f09d126ec2d623 SHA512 207e0086080e33f1e42728eb81c4543ebb21f08e2a743fbd29d64f3f5ee21a1f12c9b298fcc64df6eae646900c7858ba4a845a9b510d525f2582359b7c6a50aa
+DIST wcwidth-0.2.11.tar.gz 99709 BLAKE2B 543eb98d7b49958a04a298705eacddf4bca954a0a5f2da25e49da1d2bc7226b1fe5b58079bbf372e6ddc27d66302527cc6440fc034748a1a035458fd658349be SHA512 798a5f062fb3825ac6a4942e50dbff270962715e05e2ed40e465040264cfb4096aa6c857b4338fa2dc14918365e9e73cf9b722ee140bc257d79b00941ed1b705
DIST wcwidth-0.2.8.tar.gz 61713 BLAKE2B ca3d0c58e2ccab0fbb5493aacc8df81e9dc1faf7572543b7aa277875d617e0d4dc0c5ff6032f5f0f3846f52f26c407ddc5dd941780411572bce8ddc467a33dd7 SHA512 4a9ac4a3068c8ac25a7073d6c5e5782c3915184929ee191a2169eca510668e6e0b15856e71bd8b8d4c580767542d695b25a370329e95da317295104b962737f1
DIST wcwidth-0.2.9.tar.gz 66133 BLAKE2B 7df656c139c228324427e6be9cefe3496b7b5e55d7353f062ae4cb3d7d5988f1e5e03e11122c0e045b7a93abd95139fc2ac8a81a4d079518cc8c6fa747d2ff00 SHA512 8aff2ce67d8f331c4c75907f14ec602f4829d39e3f89af640d598e075165a011e41a5451a333bc2f6c95f33a4b9ca8ae1a5d02efe4f79acc988d60b85bf5929b
diff --git a/dev-python/wcwidth/wcwidth-0.2.11.ebuild b/dev-python/wcwidth/wcwidth-0.2.11.ebuild
new file mode 100644
index 000000000000..d1b459745990
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.2.11.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="
+ https://pypi.org/project/wcwidth/
+ https://github.com/jquast/wcwidth/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}
+
+python_install_all() {
+ docinto docs
+ dodoc docs/intro.rst
+ distutils-r1_python_install_all
+}