summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-29 06:31:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-29 06:31:10 +0200
commitf6e60002f26fed549a2b85c303a2d486c8bc8428 (patch)
treee109e9a5436276a2febc03ea898c14cf42e03cb9 /dev-python/wcwidth
parentdev-python/cycler: Bump to 0.12.0 (diff)
downloadgentoo-f6e60002f26fed549a2b85c303a2d486c8bc8428.tar.gz
gentoo-f6e60002f26fed549a2b85c303a2d486c8bc8428.tar.bz2
gentoo-f6e60002f26fed549a2b85c303a2d486c8bc8428.zip
dev-python/wcwidth: Bump to 0.2.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wcwidth')
-rw-r--r--dev-python/wcwidth/Manifest1
-rw-r--r--dev-python/wcwidth/wcwidth-0.2.7.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/wcwidth/Manifest b/dev-python/wcwidth/Manifest
index 03681df6a847..fca5e63e18b8 100644
--- a/dev-python/wcwidth/Manifest
+++ b/dev-python/wcwidth/Manifest
@@ -1 +1,2 @@
DIST wcwidth-0.2.6.gh.tar.gz 51990 BLAKE2B 8561e06aaf92f48246bacfb4012358067d81d4d9eeb33a0406eb012b5c22841ac66ff5760df2d5ea6a5d48a1880b4b9cbbcddf7a5eba5f663f6a559005f657ad SHA512 1f97cb6ef6a804da1d062b8dafb146a3e21261e63a644bad88bed74101be1371c753c2645db5ad25868fe9641fce9b13bd5dc920496b00e1d73d406f69631ac9
+DIST wcwidth-0.2.7.gh.tar.gz 54601 BLAKE2B 5ffd919e38c1e6f160e4c5ac007c42635d93fb9300338f51928db8bf19c25fc4ac6624e8633d2166435878090a130ea2cd2a0b854db10519983f0fe4d0307a6d SHA512 3044d66bd97b05904766fa29fe3c66599767bf79361081a55f4e605f2015c990b0f1934ae875f853f4f6e8acbef1f6a56492ba63eda5b5a14dd83d0cc34588d2
diff --git a/dev-python/wcwidth/wcwidth-0.2.7.ebuild b/dev-python/wcwidth/wcwidth-0.2.7.ebuild
new file mode 100644
index 000000000000..13a48660e0ef
--- /dev/null
+++ b/dev-python/wcwidth/wcwidth-0.2.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Measures number of Terminal column cells of wide-character codes"
+HOMEPAGE="
+ https://pypi.org/project/wcwidth/
+ https://github.com/jquast/wcwidth/
+"
+SRC_URI="
+ https://github.com/jquast/wcwidth/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov-append::' \
+ -e 's:--cov-report=html::' \
+ -e 's:--cov=wcwidth::' \
+ -i tox.ini || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ docinto docs
+ dodoc docs/intro.rst
+ distutils-r1_python_install_all
+}