summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 23:13:58 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 23:45:36 -0600
commitecd9d6d1d8df2b8fc11f95c0e25bfd27833afa19 (patch)
treef13b8a550c30e6390cfd5e5d1b209cca9a7c0f59 /dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild
parentdev-python/pyroute2: initial commit (diff)
downloadgentoo-ecd9d6d1d8df2b8fc11f95c0e25bfd27833afa19.tar.gz
gentoo-ecd9d6d1d8df2b8fc11f95c0e25bfd27833afa19.tar.bz2
gentoo-ecd9d6d1d8df2b8fc11f95c0e25bfd27833afa19.zip
dev-python/weakrefmethod: initial add
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild')
-rw-r--r--dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild b/dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild
new file mode 100644
index 000000000000..3de8b7a72bdd
--- /dev/null
+++ b/dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of WeakMethod from Python 3.4 to Python 2.6+"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND=""