summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 11:00:03 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 11:00:03 +0200
commitbc7d36add811b2d951736a943e1ddfad06081c0d (patch)
tree1c640e2349164c2fd1ab52d35f4d9dbcfcc23e67 /dev-python/weberror/weberror-0.13.1.ebuild
parentdev-python/jonpy: Bump (diff)
downloadgentoo-bc7d36add811b2d951736a943e1ddfad06081c0d.tar.gz
gentoo-bc7d36add811b2d951736a943e1ddfad06081c0d.tar.bz2
gentoo-bc7d36add811b2d951736a943e1ddfad06081c0d.zip
dev-python/weberror: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/weberror/weberror-0.13.1.ebuild')
-rw-r--r--dev-python/weberror/weberror-0.13.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/weberror/weberror-0.13.1.ebuild b/dev-python/weberror/weberror-0.13.1.ebuild
new file mode 100644
index 000000000000..767a8228190d
--- /dev/null
+++ b/dev-python/weberror/weberror-0.13.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="WebError"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Web Error handling and exception catching"
+HOMEPAGE="https://pypi.python.org/pypi/WebError"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/paste-1.7.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/tempita[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/webtest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}