summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 13:45:35 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 13:50:50 +0200
commit4104874cf9f1d734e22630c278621d2e2b2229b2 (patch)
treee0161d4c12e47757232b9edfad36aba4830cf54e /dev-python/webob/webob-1.8.5-r1.ebuild
parentdev-python/webob: Stabilize 1.8.5-r3 ALLARCHES (diff)
downloadgentoo-4104874cf9f1d734e22630c278621d2e2b2229b2.tar.gz
gentoo-4104874cf9f1d734e22630c278621d2e2b2229b2.tar.bz2
gentoo-4104874cf9f1d734e22630c278621d2e2b2229b2.zip
dev-python/webob: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/webob/webob-1.8.5-r1.ebuild')
-rw-r--r--dev-python/webob/webob-1.8.5-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/webob/webob-1.8.5-r1.ebuild b/dev-python/webob/webob-1.8.5-r1.ebuild
deleted file mode 100644
index 939aac364d8b..000000000000
--- a/dev-python/webob/webob-1.8.5-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7}} )
-
-inherit distutils-r1
-
-MY_PN=WebOb
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="WSGI request and response object"
-HOMEPAGE="https://webob.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test"
-
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/sphinx-1.7.5[${PYTHON_USEDEP}]
- dev-python/alabaster[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/pytest-3.1.0[${PYTHON_USEDEP}]
- )
-"
-
-RESTRICT="!test? ( test )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- fi
-}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}