summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/webob
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/webob')
-rw-r--r--dev-python/webob/Manifest2
-rw-r--r--dev-python/webob/files/webob-1.0.7-tests.patch27
-rw-r--r--dev-python/webob/files/webob-1.2.3-tests.patch24
-rw-r--r--dev-python/webob/metadata.xml8
-rw-r--r--dev-python/webob/webob-1.4.1.ebuild44
-rw-r--r--dev-python/webob/webob-1.4.ebuild44
6 files changed, 149 insertions, 0 deletions
diff --git a/dev-python/webob/Manifest b/dev-python/webob/Manifest
new file mode 100644
index 000000000000..f50f79d7357f
--- /dev/null
+++ b/dev-python/webob/Manifest
@@ -0,0 +1,2 @@
+DIST WebOb-1.4.1.tar.gz 671495 SHA256 12f8b98390befc47336d2c0e5bad9cc48609d808eabb3f8675dc1027a3a9e9db SHA512 71be0389018289884158c5f3b99d1e1185bd29ab975ea59008fd71bf1188d25130e1852422dcedf7ffe3303d87caf02d62a143229b9ae196dd62f64deb7f7328 WHIRLPOOL d2803552592813c4b5ea4291e9a3aac6aa26397b903a8372f8e1fd601d46fb5f7105dcfd42e14de974a352e75945bf61945e0f36928d6a3fd8afa8bdd195d35b
+DIST WebOb-1.4.tar.gz 633302 SHA256 0819838204e2a6823e42bf2227898fdf3f306f7619bf328e25855a0d1ca20399 SHA512 0cf1a21b7d863c355e445f0e9f898ffb1c4c39099532a86d830c1be5d84efc0c6f3e8151a283cfd1cb5bebcb1fe78a2b6b269cbc130863679a017565a2539a37 WHIRLPOOL abfc696b7f50a74edd3d84099365f802f5be0eddf56a1c128f6e026c30bdeddc1b58c6bb45d4281ee4fb3d7937888d8065b01f93a363c82cd9cd1834eb2378da
diff --git a/dev-python/webob/files/webob-1.0.7-tests.patch b/dev-python/webob/files/webob-1.0.7-tests.patch
new file mode 100644
index 000000000000..a86f88c69a93
--- /dev/null
+++ b/dev-python/webob/files/webob-1.0.7-tests.patch
@@ -0,0 +1,27 @@
+https://bitbucket.org/ianb/webob/issue/11
+https://bitbucket.org/ianb/webob/changeset/145b64e724eb
+
+--- tests/test_misc.py
++++ tests/test_misc.py
+@@ -130,7 +130,8 @@
+
+
+ def test_multidict_cgi():
+- fs = cgi.FieldStorage()
++ env = {'QUERY_STRING': ''}
++ fs = cgi.FieldStorage(environ=env)
+ fs.filename = '\xc3\xb8'
+ plain = MultiDict(key='\xc3\xb8', fs=fs)
+ ua = UnicodeMultiDict(multi=plain, encoding='utf-8')
+--- tests/test_multidict.py
++++ tests/test_multidict.py
+@@ -187,7 +187,8 @@
+ d = self._get_instance()
+ d.decode_keys = True
+
+- fs = cgi.FieldStorage()
++ env = {'QUERY_STRING': ''}
++ fs = cgi.FieldStorage(environ=env)
+ fs.name = 'a'
+ self.assertEqual(d._decode_value(fs).name, 'a')
+
diff --git a/dev-python/webob/files/webob-1.2.3-tests.patch b/dev-python/webob/files/webob-1.2.3-tests.patch
new file mode 100644
index 000000000000..4fc3fbab7c3c
--- /dev/null
+++ b/dev-python/webob/files/webob-1.2.3-tests.patch
@@ -0,0 +1,24 @@
+From 3a2c16f2f72dbca5ddfce7f649daf426c2125fed Mon Sep 17 00:00:00 2001
+From: Aaron DeVore <aaron.devore@gmail.com>
+Date: Tue, 30 Oct 2012 11:55:30 -0700
+Subject: [PATCH] Fix issue #75: depending on dict order in test_headers2
+
+---
+ tests/test_request.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/test_request.py b/tests/test_request.py
+index f219d36..3e38e7a 100644
+--- a/tests/test_request.py
++++ b/tests/test_request.py
+@@ -2662,7 +2662,7 @@ def test_headers2(self):
+ self.assertTrue(i in r.headers and
+ 'HTTP_'+i.upper().replace('-', '_') in r.environ)
+ r.headers = {'Server':'Apache'}
+- self.assertEqual(list(r.environ.keys()), ['a', 'HTTP_SERVER'])
++ self.assertEqual(set(r.environ.keys()), set(['a', 'HTTP_SERVER']))
+
+ def test_host_url(self):
+ # Request has a read only property host_url that combines several
+--
+1.8.1.6
diff --git a/dev-python/webob/metadata.xml b/dev-python/webob/metadata.xml
new file mode 100644
index 000000000000..b66579ea54e7
--- /dev/null
+++ b/dev-python/webob/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">WebOb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/webob/webob-1.4.1.ebuild b/dev-python/webob/webob-1.4.1.ebuild
new file mode 100644
index 000000000000..0fa903e3a6c6
--- /dev/null
+++ b/dev-python/webob/webob-1.4.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN=WebOb
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ "${PYTHON}" setup.py build_sphinx || die
+ fi
+}
+
+python_test() {
+ nosetests -w tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/webob/webob-1.4.ebuild b/dev-python/webob/webob-1.4.ebuild
new file mode 100644
index 000000000000..819a069df051
--- /dev/null
+++ b/dev-python/webob/webob-1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN=WebOb
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="WSGI request and response object"
+HOMEPAGE="http://webob.org/ http://pypi.python.org/pypi/WebOb"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ "${PYTHON}" setup.py build_sphinx || die
+ fi
+}
+
+python_test() {
+ nosetests -w tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}