summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/websockify
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/websockify')
-rw-r--r--dev-python/websockify/Manifest1
-rw-r--r--dev-python/websockify/metadata.xml15
-rw-r--r--dev-python/websockify/websockify-0.6.0.ebuild19
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/websockify/Manifest b/dev-python/websockify/Manifest
new file mode 100644
index 000000000000..7d7f912b8c88
--- /dev/null
+++ b/dev-python/websockify/Manifest
@@ -0,0 +1 @@
+DIST websockify-0.6.0.zip 312980 SHA256 09fd696fc528fcc915e66d43006c4e73e4e009233724d45e365ada1f8b01251c SHA512 f7792b0140fd5170b39dd0cabdf176ea8db43b148068ec336ddf61b70e166f6f935411901675c13657efee7e9cdf4de78bc74b0e371ce91811098b16a11a2915 WHIRLPOOL 46199706a3c8988aa7aec6018ee5defe50a289023132f48bd5d48ed486e17317b7b3a1661e367b818e2cd9445eabd3672f25155f1117ddb641be9ecb9a54ca46
diff --git a/dev-python/websockify/metadata.xml b/dev-python/websockify/metadata.xml
new file mode 100644
index 000000000000..07db39f04d75
--- /dev/null
+++ b/dev-python/websockify/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ WebSockets support for any application/server
+ </longdescription>
+ <upstream>
+ <remote-id type="github">kanaka/websockify</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/websockify/websockify-0.6.0.ebuild b/dev-python/websockify/websockify-0.6.0.ebuild
new file mode 100644
index 000000000000..265d0d051f5f
--- /dev/null
+++ b/dev-python/websockify/websockify-0.6.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/kanaka/${PN}/archive/v${PV}.zip -> ${P}.zip"
+DESCRIPTION="WebSockets support for any application/server"
+HOMEPAGE="https://github.com/kanaka/websockify"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"