summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 21:03:28 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 21:03:28 +0200
commitbe8255cd1663c658be74a3e88680d1903b7d6c8e (patch)
tree816a11f8f80b9166c35b438af0031d3308efff73 /dev-python/webtest
parentdev-python/mimeparse: Bump (diff)
downloadgentoo-be8255cd1663c658be74a3e88680d1903b7d6c8e.tar.gz
gentoo-be8255cd1663c658be74a3e88680d1903b7d6c8e.tar.bz2
gentoo-be8255cd1663c658be74a3e88680d1903b7d6c8e.zip
dev-python/webtest: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/Manifest1
-rw-r--r--dev-python/webtest/webtest-2.0.21.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/webtest/Manifest b/dev-python/webtest/Manifest
index 2469a75672e9..af9550e75372 100644
--- a/dev-python/webtest/Manifest
+++ b/dev-python/webtest/Manifest
@@ -2,3 +2,4 @@ DIST WebTest-1.4.3.zip 80008 SHA256 0439d951afdf6c58d19e0a83e30855d0bb7e35ab177d
DIST WebTest-2.0.16.zip 88232 SHA256 24ad0c9ee377f16df4d0bd626a64a75eec901852ac788bdb70e0261bff0026eb SHA512 da09abba8ed52c8d673acf547f47df6919b534b33b746944610fc78bd3695f36e3718f89e68f8aec7852b6cf98da0f0b5500dfe9427fd7926e5304ad216eafbb WHIRLPOOL 68d392000c8767ef9b5d4cc657bd6e99ec75eb4cb20cacdabdcca87942894b290f957854fb7dfb7c9eb8312877575c4e4d258e78c05f985e972b02ee04ec2643
DIST WebTest-2.0.17.zip 88435 SHA256 36457f708a57e4295a2c05aaf47b620b66e25429dd9170c59d0718ff7934a0b7 SHA512 5a1e26108af1cb5fc5db10bf10a48c98815ccacb84c692ecedfc6ef02427bedaa3bdfc466a89faa51c82474da2bd393aae5f17821c516966999c5d2e5f12628d WHIRLPOOL 2c7c504fd6087cc116f28de8113f456901535d6d098845bc1b3551264ee9ea5c7bc9fad4699015eecb974a0423edf60e0715d93025ed3d05da91a6235dc6e1fb
DIST WebTest-2.0.18.zip 88440 SHA256 beb569e6d707cb4cd82c226c97b7e1f41cd62bae656d89e687107eef8376c7fd SHA512 98f61325a2cb0db3c0aec317f3acf8a741531fece33fa359615cdee8738cb2c4523156971c1fd420c900b0d3ece4adc15f2e77975f40376f0e58370ff7b5fe79 WHIRLPOOL 5057d1c1518656f4869a6baa41617815972044b91b2dbc8d56b2adcb379fefcf01de57b90cd7ee98664c004619f2170d5a6f0fd9a175a83ef758af0ee7d5c48c
+DIST WebTest-2.0.21.tar.gz 66866 SHA256 3dc92ecd7604e21fc7c97578e4c43aff2a67cebdd4884a2aa804d85e85b34b55 SHA512 21f58ee9192fd0eb0eb2d88179ffc015aa5cf04c8004db251bd65d13d54c34b9e6b5fc9fdd8e9fcbbc18fcfb2be714c0691b2ef034318861262f8705b4a44610 WHIRLPOOL f87c877dc30dcee5c86225849d27a1a3b5504f656e4c68ff88273c665f1684cb21f0e31ebcdd4b6981e1bc5269d8057379f78d90c708de8e319846a5aa27669d
diff --git a/dev-python/webtest/webtest-2.0.21.ebuild b/dev-python/webtest/webtest-2.0.21.ebuild
new file mode 100644
index 000000000000..72f15301435a
--- /dev/null
+++ b/dev-python/webtest/webtest-2.0.21.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ https://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+# nose<1.3.0 appears a leftover never updated in requires.txt. tests pass fine with latest
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# Makes testing easier; otherwise we get errors from pkg_resources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Prevent un-needed d'loading during doc build
+ sed -s 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die
+ fi
+}
+
+python_test() {
+ # Tests raise ImportErrors with our default PYTHONPATH.
+ local -x PYTHONPATH=
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( html/. )
+ distutils-r1_python_install_all
+}