summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-23 15:08:07 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-23 15:08:07 +0200
commit46c47bc7a174f94c77eb725bc0f91160eddc840d (patch)
tree6ae05faa72b867465f98a2b0214b15dd0e77fb29 /dev-python/werkzeug/werkzeug-0.12.2.ebuild
parentnet-analyzer/prometheus: Version bump to 1.7.1 (diff)
downloadgentoo-46c47bc7a174f94c77eb725bc0f91160eddc840d.tar.gz
gentoo-46c47bc7a174f94c77eb725bc0f91160eddc840d.tar.bz2
gentoo-46c47bc7a174f94c77eb725bc0f91160eddc840d.zip
dev-python/werkzeug: Version bump to 0.12.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/werkzeug/werkzeug-0.12.2.ebuild')
-rw-r--r--dev-python/werkzeug/werkzeug-0.12.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/werkzeug/werkzeug-0.12.2.ebuild b/dev-python/werkzeug/werkzeug-0.12.2.ebuild
new file mode 100644
index 000000000000..2791a1bf1602
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.12.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.python.org/pypi/Werkzeug https://github.com/pallets/werkzeug"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ esetup.py test
+}