summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-25 19:50:37 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-25 20:04:56 -0400
commitdc24dcfe979c3456c644e7c5b32a8f5e22428424 (patch)
tree66585c12c500dfb2ae6086d536c83eb17b9a0891 /dev-python/wheel
parentdev-python/simplejson: version bump to 3.15.0 (diff)
downloadgentoo-dc24dcfe979c3456c644e7c5b32a8f5e22428424.tar.gz
gentoo-dc24dcfe979c3456c644e7c5b32a8f5e22428424.tar.bz2
gentoo-dc24dcfe979c3456c644e7c5b32a8f5e22428424.zip
dev-python/wheel: version bump to 0.31.1
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest1
-rw-r--r--dev-python/wheel/wheel-0.31.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index 74af11dbdc7a..267a1767e3b8 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,2 +1,3 @@
DIST wheel-0.29.0.tar.gz 54143 BLAKE2B 8f29c81b9b3c8ee419c26f04e09f437a2113716f5096e1b6e21f23e6a7426e58b7ee00c0846cfcd816670bee4dd908ef577e4142fae546d4ea643af2c2612049 SHA512 b72dec3cf71e3d87c611ff41f1381ed7f2c654edb50c808fb4fd0f552bab3572434495bf18c36d2ecc7cb8b355782054d3d6dedd5589ffda15027e72cff24602
DIST wheel-0.30.0.tar.gz 43087 BLAKE2B 796a57298571a9430094be93f38c679941157679d5a75d7d5da88be4d1f970f5aeb9810bbaaa31c77b71959b3c6eadcd618314ab3fa82b959c592c72b8171c0a SHA512 d39fb683ca2937745b057464ec17f5fab0475c2b1225cc4c84f1b0e8cd61a4bb039730dafdaa687f7b054ce080c4b7acbd3196045db14e015585536fcf498f84
+DIST wheel-0.31.1.tar.gz 38574 BLAKE2B 83684b33d587fe4a9593aa1b45c8e3f9543a97f80767c973f2b796bd23191af489760507fc491e4c471d804cb8c8a969de2e6cc509beeae66e1911650be5d725 SHA512 38854a54722cd8b3ff3b53bc62fc56255b37adac5ffb3fc1b0cb5f252a3cebd84390f3bac0600835c64bbec158337a7a13f0725dda47a659183fd038986cdd75
diff --git a/dev-python/wheel/wheel-0.31.1.ebuild b/dev-python/wheel/wheel-0.31.1.ebuild
new file mode 100644
index 000000000000..f0aa2dd6026d
--- /dev/null
+++ b/dev-python/wheel/wheel-0.31.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.org/project/wheel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# dev-python/keyring
+# dev-python/keyrings_alt
+# dev-python/ed25519ll
+# dev-python/pytest[${PYTHON_USEDEP}]
+# )
+#"
+
+# Fails somehow
+RESTRICT=test
+
+python_test() {
+ sed \
+ -e 's:--cov=wheel::g' \
+ -i setup.cfg || die
+ py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "Signature support" \
+ dev-python/keyring \
+ dev-python/keyrings_alt \
+ dev-python/ed25519ll
+}