summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-17 16:15:10 +0000
committerSam James <sam@gentoo.org>2021-01-17 16:16:03 +0000
commitf7dcabba6af6dbc3729ce0ec69cf31ece6f255f7 (patch)
tree2f24a4e472ef1a46487bd63490ad9aa520c7f81f /dev-python/whisper/whisper-1.1.7.ebuild
parentdev-python/path-py: bump to 15.0.1 (diff)
downloadgentoo-f7dcabba6af6dbc3729ce0ec69cf31ece6f255f7.tar.gz
gentoo-f7dcabba6af6dbc3729ce0ec69cf31ece6f255f7.tar.bz2
gentoo-f7dcabba6af6dbc3729ce0ec69cf31ece6f255f7.zip
dev-python/whisper: bump to 1.1.7
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/whisper/whisper-1.1.7.ebuild')
-rw-r--r--dev-python/whisper/whisper-1.1.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/whisper/whisper-1.1.7.ebuild b/dev-python/whisper/whisper-1.1.7.ebuild
new file mode 100644
index 000000000000..201d0c86240a
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+# PyPI tarballs don't contain tests
+# https://github.com/graphite-project/whisper/pull/253
+SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+#python_test() {
+# py.test || die "tests failed with ${EPYTHON}"
+#}