summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 07:57:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 08:34:04 +0200
commit8581c409fab86634db9530f04f7090395dde04d7 (patch)
treeac6ca3400f5edffc9a7931041a1e7ddfa94069f6 /dev-python/whisper
parentdev-python/PyPDF2: Bump to 1.28.1 (diff)
downloadgentoo-8581c409fab86634db9530f04f7090395dde04d7.tar.gz
gentoo-8581c409fab86634db9530f04f7090395dde04d7.tar.bz2
gentoo-8581c409fab86634db9530f04f7090395dde04d7.zip
dev-python/whisper: Bump to 1.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/whisper')
-rw-r--r--dev-python/whisper/Manifest1
-rw-r--r--dev-python/whisper/whisper-1.1.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/whisper/Manifest b/dev-python/whisper/Manifest
index d32e1fd21e9d..ee7e0bccdfa2 100644
--- a/dev-python/whisper/Manifest
+++ b/dev-python/whisper/Manifest
@@ -1 +1,2 @@
+DIST whisper-1.1.10.gh.tar.gz 39459 BLAKE2B 998c4335236ace6b28f11b23fe74d3b618ba2f56939a3e9766e7010eb6b5d9bbdb46de83ba41dd926d3d38e738851133dc9805a4c79bd80dd67897e627147550 SHA512 291d441287ba090157fa01a7feb6985a6e1f057f4dae0f9133e2355e00f5fe219e10de339ecad3438a56b8dec97def14496d85c7a5fc5fc7611771bb3de08de8
DIST whisper-1.1.8.gh.tar.gz 39117 BLAKE2B 591a3529725f300c6d8bab40444bdd41bcfe3d832893e954295d5387e047e2a639db4235131cd90fdb686395d51afccf30f64a52e194e4cd8e00b86e38f841d6 SHA512 0452c684128a750e30e926aee0cfd6c94f129eeb561246f9e1c66d7cf1f27f139df84f91e935237f89d0b4fac98678108568cfb94c2ab4138480f4db31471ab4
diff --git a/dev-python/whisper/whisper-1.1.10.ebuild b/dev-python/whisper/whisper-1.1.10.ebuild
new file mode 100644
index 000000000000..d587c6d47c45
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="
+ https://github.com/graphite-project/whisper/
+ https://pypi.org/project/whisper/
+"
+SRC_URI="
+ https://github.com/graphite-project/whisper/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # not a regression (fails the same with the previous version)
+ # https://github.com/graphite-project/whisper/issues/321
+ test_whisper.py::TestWhisper::test_resize_with_aggregate
+)