summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/whoosh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/Manifest2
-rw-r--r--dev-python/whoosh/metadata.xml25
-rw-r--r--dev-python/whoosh/whoosh-2.6.0.ebuild57
-rw-r--r--dev-python/whoosh/whoosh-2.7.0.ebuild53
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-python/whoosh/Manifest b/dev-python/whoosh/Manifest
new file mode 100644
index 000000000000..f842eddb744e
--- /dev/null
+++ b/dev-python/whoosh/Manifest
@@ -0,0 +1,2 @@
+DIST Whoosh-2.6.0.zip 1193541 SHA256 7de7bc4d00a6d051dbb360b48eb7f3cd002373d87252fb0b284a3c9c453a7677 SHA512 e50e47ec0d1c65ad3c7d657586f5380a1be748945c1ce964305fa68b99379f0da676faef6f0ca45ef151df7be71150601162ee966f3aaf84047a20bca36f7e37 WHIRLPOOL c42e9760833db7186f3df5946f6dd071288cfccf2eaefba95520a2415ca377c49cf74307b3fa2c9e655f134b086ae637e5db06330248b4a27e12175920f3c7b8
+DIST Whoosh-2.7.0.zip 1080985 SHA256 733df1ad4142fcd1e8f3259070de0521d272d7685e2febc0f4fdd1668cfe0d48 SHA512 5126a9ed5ef50af391905347c7aa1c1cc7d100213c29f5a5f67fcfabab9cdcfcd14a6b75735df8e343f61254d1fec8610f0e1260167a321ab303a0a55b02673f WHIRLPOOL 6a35448280e3c6382b8a4b50432d5def3a910d9af95d35afc11544030b69f0103aae910bbf91cb5942ec80f10a848bbd32dbd828c71482f5e2fc15a9cd29c249
diff --git a/dev-python/whoosh/metadata.xml b/dev-python/whoosh/metadata.xml
new file mode 100644
index 000000000000..861b39a466ef
--- /dev/null
+++ b/dev-python/whoosh/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <maintainer>
+ <email>bugs@bergstroem.nu</email>
+ <name>Johan Bergström</name>
+ </maintainer>
+ <longdescription lang="en">
+ Whoosh is a fast, featureful full-text indexing and searching
+ library implemented in pure Python. Programmers can use it to
+ easily add search functionality to their applications and websites.
+ Every part of how Whoosh works can be extended or replaced to meet
+ your needs exactly.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">Whoosh</remote-id>
+ <remote-id type="bitbucket">mchaput/whoosh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/whoosh/whoosh-2.6.0.ebuild b/dev-python/whoosh/whoosh-2.6.0.ebuild
new file mode 100644
index 000000000000..4363ff49035f
--- /dev/null
+++ b/dev-python/whoosh/whoosh-2.6.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+MY_PN="Whoosh"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
+HOMEPAGE="http://bitbucket.org/mchaput/whoosh/wiki/Home/ http://pypi.python.org/pypi/Whoosh/"
+SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.zip"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ # (backport from upstream)
+ sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
+
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://bitbucket.org/mchaput/whoosh/issue/403/
+ use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html
+}
+
+# Restrict to test phase; a few random tests fail without it
+src_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( README.txt )
+ use doc && local HTML_DOCS=( docs/source/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/whoosh/whoosh-2.7.0.ebuild b/dev-python/whoosh/whoosh-2.7.0.ebuild
new file mode 100644
index 000000000000..b91a78f509c7
--- /dev/null
+++ b/dev-python/whoosh/whoosh-2.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+MY_PN="Whoosh"
+
+inherit distutils-r1
+
+DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
+HOMEPAGE="http://bitbucket.org/mchaput/whoosh/wiki/Home/ http://pypi.python.org/pypi/Whoosh/"
+SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.zip"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ # (backport from upstream)
+ sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
+
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://bitbucket.org/mchaput/whoosh/issue/403/
+ use doc && sphinx-build -b html -c docs/source/ docs/source/ docs/source/build/html
+}
+
+python_test() {
+ # https://bitbucket.org/mchaput/whoosh/issue/412/tarball-of-whoosh-270-pypi-missing-english
+ # tarball missing a file english-words.10.gz which when added sees all tests pass.
+ esetup.py test
+}
+
+python_install_all() {
+ local DOCS=( README.txt )
+ use doc && local HTML_DOCS=( docs/source/build/html/. )
+ distutils-r1_python_install_all
+}